Problems setting up build agent on Vista

Hi There,

I am having problems getting my TeamCity server to work with a build agent I have installed on Vista.

Right now, the TeamCity server is installed on a Linux server. I have authorised a seperate build agent installed on an Ubuntu machine already. However, I am unable to get my second agent (installed on Vista) to be seen by the TeamCity server.

I have set the agent up with the defaults and configured it to point at the build server and I have also left the ownPort setting as 9090, but no joy. I am reasonably convinced that it is down to a permissioning issue, but, has anyone else had this problem? Could someone give me some pointers so I can get it resolved?

12 comments
Comment actions Permalink

Hello Noodle,

  Please make sure your linux server can access port 9090 on your Vista.

  Please also take a look at build agent log: buildAgent/logs/teamcity-agent.log

  and server log TeamCity/logs/teamcity-server.log .

  There should be some information on what's going on.

  Hope this helps,
  KIR

0
Comment actions Permalink

Hi Kiril,

thanks for replying

Here is the last entry from the log after I restart the service:

[2009-05-13 21:50:05,113]   INFO -    jetbrains.buildServer.AGENT - Starting TeamCity agent
[2009-05-13 21:50:06,563]   INFO -    jetbrains.buildServer.AGENT - Calculating plugins signature for possible upgrade
[2009-05-13 21:50:06,570]   INFO -    jetbrains.buildServer.AGENT - Build Agent version: 8975, plugins signature: 0
[2009-05-13 21:50:06,640]   WARN -    jetbrains.buildServer.AGENT - Calculating CPU benchmark index...
[2009-05-13 21:50:23,937]   WARN -    jetbrains.buildServer.AGENT - CPU benchmark index is set to 179
[2009-05-13 21:50:23,976]   WARN - ent.impl.AgentToolsManagerImpl - Tool ant was not found at C:\BuildAgent\plugins\ant
[2009-05-13 21:50:23,976]   WARN - ent.impl.AgentToolsManagerImpl - Tool idea was not found at C:\BuildAgent\plugins\idea
[2009-05-13 21:50:23,977]   WARN - ent.impl.AgentToolsManagerImpl - Tool maven was not found at C:\BuildAgent\plugins\maven
[2009-05-13 21:50:24,651]   INFO -    jetbrains.buildServer.AGENT - Calculating plugins signature for possible upgrade
[2009-05-13 21:50:24,652]   INFO -    jetbrains.buildServer.AGENT - Build Agent version: 8975, plugins signature: 0
[2009-05-13 21:50:24,671]   WARN - ent.impl.AgentToolsManagerImpl - Tool ant was not found at C:\BuildAgent\plugins\ant
[2009-05-13 21:50:24,671]   WARN - ent.impl.AgentToolsManagerImpl - Tool idea was not found at C:\BuildAgent\plugins\idea
[2009-05-13 21:50:24,671]   WARN - ent.impl.AgentToolsManagerImpl - Tool maven was not found at C:\BuildAgent\plugins\maven
[2009-05-13 21:50:24,674]   INFO - rver.plugins.PluginManagerImpl - ===========================================================
[2009-05-13 21:50:24,675]   INFO - rver.plugins.PluginManagerImpl - Scanning plugin folder: C:\BuildAgent\plugins
[2009-05-13 21:50:24,677]   INFO - rver.plugins.PluginManagerImpl - Found 0 plugins: []
[2009-05-13 21:50:24,677]   INFO - rver.plugins.PluginManagerImpl - Start intializing plugins...
[2009-05-13 21:50:24,677]   INFO - rver.plugins.PluginsCollection - No plugins were loaded with standalone classloaders
[2009-05-13 21:50:24,677]   INFO - rver.plugins.PluginsCollection - Load shared classloader for 0 plugins []
[2009-05-13 21:50:24,678]   INFO - rver.plugins.PluginManagerImpl - Loaded 0 plugins: []
[2009-05-13 21:50:24,678]   INFO - rver.plugins.PluginManagerImpl - ===========================================================
[2009-05-13 21:50:24,730]   INFO - rectories.DirectoryCleanerImpl - Cannot locate .old for path 'C:\BuildAgent\temp\cache'. Deleting files in place.
[2009-05-13 21:50:24,741]   INFO -    jetbrains.buildServer.AGENT - Start build agent
[2009-05-13 21:50:24,809]   WARN -    jetbrains.buildServer.AGENT - Starting agent Web server on port 9090
[2009-05-13 21:50:24,880]   INFO -    jetbrains.buildServer.AGENT - Agent Web server started
[2009-05-13 21:50:24,894]   INFO - agent.impl.AgentPortFileWriter - Writing agent runtime file to C:\BuildAgent\logs\buildAgent.port
[2009-05-13 21:50:24,894]   INFO - agent.impl.AgentPortFileWriter - Launcher version is 8975
[2009-05-13 21:50:24,896]   INFO - agent.impl.AgentPortFileWriter - Writing agent runtime file to C:\BuildAgent\logs\buildAgent.port  DONE!
[2009-05-13 21:50:24,897]   INFO -    jetbrains.buildServer.AGENT - Build agent started
[2009-05-13 21:50:25,005]   INFO - buildServer.AGENT.registration - Registering on server: [name: Vista, ownAddress: 169.254.80.153, ownPort: 9090, buildId: <not running build>, availableRunners: [simpleRunner], availableVcs: []]
[2009-05-13 21:51:25,502]   WARN - buildServer.AGENT.registration - Call http://magneto:8111/RPC2 buildServer.registerAgent2: org.apache.xmlrpc.XmlRpcException: java.lang.Exception: jetbrains.buildServer.CannotPingAgentException: Unable to ping agent Vista. Please check firewall on agent machine
[2009-05-13 21:51:25,502]   WARN - buildServer.AGENT.registration - Connection to TeamCity server is probably lost. Will be trying to restore it. Take a look at logs/teamcity-agent.log for details (unless you're using custom logging).

Now, I know you may look at this and say "there is a firewall on the agent machine that is preventing this from working". However, I have disabled my firewall on the agent machine and this has not helped.

Is there a security setting on Vista that I need to change?

BR
-
Noodle King

0
Comment actions Permalink

Hi Karim,

I am having a problem quite similar to yours,
(found this thread following Kirills funny Profile Portrait...)

Could be reproduced doing...

1. setting up http://download.jetbrains.com/teamcity/TeamCity-4.5.1a.war on Debian Linux 4.0
2. secure copying jetbrains.git.zip to the plugin directory
3. configuring github-project with rake-runner
4. setting up Build Agent using the Windows Installer on Windows 2003 Server (...)
    (configured port-forwarding on the routers..., buildAgent.properties got the ownAddress=PUBLIC_IP property...,
     the ip of the wrapper.log is now pingable from the Web-Server.)
5. installing ruby on the (xna-executeable) Client
6. Running Build

Build errors

 
[11:16:14]: Unable to find bundled ruby scripts folder(C:\BuildAgent\plugins\rake-runner\lib\rb). Plugin is damaged.
7. Executing  C:\BuildAgent\work\...\rake works well.
8. Creating the folder rb in C:\BuildAgent\plugins\rake-runner\lib\ because there were only two .jar files...

Build errors

[10:49:01]: Failed to run Rake..

[10:49:01]: Unable to find Ruby interpreter in PATH.
Does the rake-runner dream it is running on Linux?
0
Comment actions Permalink

9. configured

Ruby interpreter path: If not specified the interpreter will be searched in the PATH.


and the build runs on the Agent.
This path is also visible after echo %PATH% on the Agent. So is the PATH of the linux webserver used?
Do I need an own build-config for every Agent? This looks like a design bug for me...

0
Comment actions Permalink

Hi Josef,

I am sorry, but I dont see how your issues are connected to mine?

The problem I am facing is that my TeamCity server is unable to communicate with a Vista host, whereas an Ubuntu host on the same network can.

From what I can see, you dont have a problem with communication, but instead you have a configuration issue?

If I have made a mistake, and you have had a similar problem to me, could you let me know how you fixed it?

0
Comment actions Permalink

jetbrains.buildServer.CannotPingAgentException: Unable to ping agent Vista. Please check firewall on agent machine


4. setting up Build Agent using the Windows Installer on Windows 2003 Server (...)
    (configured port-forwarding on the routers..., buildAgent.properties got the ownAddress=PUBLIC_IP property...,
     the ip of the wrapper.log is now pingable from the Web-Server.)

My first issue was, that there was no ownAddress entry in the buildAgent.properties.
Maybe you also have to enter a PUBLIC_IP, which could be pinged in a ssh-session on the webserver-machine...



0
Comment actions Permalink

Can an admin close this thread please, I need to start over.

0
Comment actions Permalink

Very nice, that you leave this thread to my "configuration" problem   
I am still interested, why there is one PATH value for many agents...

And my last meddling with your "connection" problem...
just listen to the exception text and try the ping manually...(win7...!?)

0
Comment actions Permalink

Um, thanks for your input.

I am really unsure what it is you are trying to say with that link? Are you suggesting I should install Windows 7? If so, why - as I cannot see right now how this would help me?

I think it may be better for you to start your own thread, if needed, about your problem etc. That way maybe people who are also going through the same issues could see how you got around it. As it stands, I am not entirely convinced that your issues are actually related to the problems I experienced. But, if you think they are then ok.

But, back to the original topic of this thread - setting up a build agent on Vista - I have actually managed to solve this myself.

My soloution was to simply add the ownAddress parameter to the build agent config file and specify an IP address. It isnt perfect, especially if you use dynamic addressing, but it has solved it for me. After I had done this, the agent appeared in TeamCity as unauthorised. After authorising it, it then appeared disconnected. After restarting the service it then connected. I also had the build agent service using an admin account, but this seems to work ok for me if it uses the system account as well.

So, if anyone else had the same problem, i.e. setting up a build agent on Vista, try giving this a go as it may work for you.

0
Comment actions Permalink

Oook, have you every read the 'point 4 thing'....!?

0
Comment actions Permalink

Hi Josef,

thanks for your continued input on this thread. However, maybe now is a good time to let this one come to a natural end? The original issue has been solved, so I am not sure how much interest you are going to get for your problems here.

Perhaps creating your own thread would be better for everyone else who might have been experiencing problems like yours.

0
Comment actions Permalink

I had the same problem, Installing agent on XP Pro Virtual machine..  My Team City Server was remote accross the internet with a static IP.

I added:

ownPort=9090
ownAddress=xx.xx.xx.xx ( my dynamic IP)

then i configured my router to route 9090 to my internal IP

worked ok after adding my IP, it would not before adding this property.

Hope it helps...

0

Please sign in to leave a comment.