Failed to find plugin 'Test/2.5.3'

I'm trying to run some tests using NUnit via the MSBuild builder. My script looks like this:

<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003"
         DefaultTargets="Merge"
         ToolsVersion="3.5">
  <UsingTask Condition="'$(TEAMCITY_VERSION)'!=''" TaskName="NUnitTeamCity" AssemblyFile="$(teamcity_dotnet_nunitlauncher_msbuild_task)" />

  [...]

  <Target Name="TeamCityTest" DependsOnTargets="Merge">
    <NUnitTeamCity Platform="x86" NUnitVersion="2.5.3" Assemblies="$(OutputPathMerged)\$(ProjectName).exe"/>
  </Target>

</Project>


This results in the following error:

Failed to find plugin 'Test/2.5.3'

at JetBrains.TeamCity.Utils.PluginManager.LoadExtensions(String prefix, String plugin) in c:\Agent\work\3f3d88bdf17c1223\src\Utils\src\PluginManager.cs:line 48

at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.Run2(String[] args) in c:\Agent\work\3f3d88bdf17c1223\src\NUnitBootstrap\src\NUnitLauncher2.cs:line 103

at JetBrains.BuildServer.NAntLoggers.NUnitLauncher2.Run(String[] args) in c:\Agent\work\3f3d88bdf17c1223\src\NUnitBootstrap\src\NUnitLauncher2.cs:line 45


Is there something wrong with how I invoke NUnitTeamCity?

(TeamCity v5.0.2 (build 10784) on Win7 32-bit, running under Jetty-6.1)

Regards,
Roman

3 comments
Comment actions Permalink

Since there have been no replies to the above... The thing I'm really trying to figure out is how to run NUnit tests when my test assembly is compiled by MSBuild. It used to be an .sln, using the sln2008 builder, and there were a bunch of nice easy settings for NUnit - test assembly path, NUnit version, platform - which worked flawlessly.

But then we made a change that required the project to be built from an MSBuild script instead. The MSBuild builder does not have the nice and easy NUnit settings - I really wish it did. I still just want TeamCity to run NUnit on a certain assembly. Does this really have to be part of the MSBuild script, and if so, is the code in my first post above the right way to do that?

Thanks!

0
Comment actions Permalink

Please use "NUnit-2.5.3" instead of "2.5.3" in NUnitVersion attribute value.

0
Comment actions Permalink

That has fixed it, thanks!


0

Please sign in to leave a comment.