problem with rake build in rake_ext.rb:235 (ruby 1.9.1 / win32 / teamcity 5.0.2 build 10784)

I'm trying to setup my first rake build configuration in team city and run into issue

the message is:

plugins/rake-runner/lib/rb/runner/rake_ext.rb:335:in `block in format_exception_msg': invalid backref number/name: /D:\tmp\teamcitybuildagent\workdir\8d6d51576325e29b\PerfectVision\rakefile.rb/ (RegexpError)

here is the output of "gem list"


*** LOCAL GEMS ***

rake (0.8.7)
regex (1.0.0)
test-unit (2.0.6)


running rake locally on the build agent from the working copy works ok

and the complete build log:
=========================================



[18:09:08]: Checking for changes
[18:09:12]: Clearing temporary directory: D:\tmp\teamcitybuildagent\tmp\buildTmp
[18:09:12]: Checkout directory: D:\tmp\teamcitybuildagent\workdir\8d6d51576325e29b
[18:09:12]: Updating sources: server side checkout... (10s)
[18:09:12]: [Updating sources: server side checkout...] Building incremental patch for VCS root: beanstalkappsvn
[18:09:22]: [Updating sources: server side checkout...] Repository sources transferred
[18:09:22]: [Updating sources: server side checkout...] Updating D:\tmp\teamcitybuildagent\workdir\8d6d51576325e29b
[18:09:22]: Starting build process in D:\tmp\teamcitybuildagent\workdir\8d6d51576325e29b
[18:09:22]: D:\dev\bin\ruby-1.9.1\bin/ruby.exe D:\programs\teamcity\buildAgent\plugins\rake-runner\lib\rb\runner\rakerunner.rb --rakefile AbsolutePathToTheRakeFile\rakefile.rb "SPEC_OPTS=--require 'teamcity/spec/runner/formatter/teamcity/formatter' --format Spec::Runner::Formatter::TeamcityFormatter:matrix" "CUCUMBER_OPTS=--format Teamcity::Cucumber::Formatter --expand"
[18:09:23]: (in D:/tmp/teamcitybuildagent/workdir/8d6d51576325e29b)
[18:09:23]: D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rake_ext.rb:335:in `block in format_exception_msg': invalid backref number/name: /D:\tmp\teamcitybuildagent\workdir\8d6d51576325e29b\PerfectVision\rakefile.rb/ (RegexpError)
[18:09:23]: from D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rake_ext.rb:335:in `each'
[18:09:23]: from D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rake_ext.rb:335:in `find'
[18:09:23]: from D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rake_ext.rb:335:in `format_exception_msg'
[18:09:23]: from D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rake_ext.rb:287:in `process_exception'
[18:09:23]: from D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rake_ext.rb:361:in `rescue in run'
[18:09:23]: from D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rake_ext.rb:367:in `run'
[18:09:23]: from D:/programs/teamcity/buildAgent/plugins/rake-runner/lib/rb/runner/rakerunner.rb:79:in `<main>'
[18:09:23]: Process exit code: 1
[18:09:23]: Build finished


do you have an idea what may be wrong?

Please sign in to leave a comment.