does IDEA 8 plugins compatible with teamcity 5.0?

Does plugins installed in IDEA 8 will work properly after upgrade from 4.5 to 5.0 or upgrade is necessary?

5 comments
Comment actions Permalink

TeamCity 5.0 IDEA plugin supports IntelliJ IDEA 7/8 and 9.

0
Comment actions Permalink

Thanks for reply Pavel. Don't sure the question was clear, i meant does plugin upgrade required, if was installed in ide prior to upgrade from 4.5 up 5?

0
Comment actions Permalink

Yes, plugin upgrade is required. Actually once you will try to connect to TeamCity 5.0 from 4.5 plugin you will be notified that plugin upgrade needed.

0
Comment actions Permalink

Hello, friends

I have a contrary case: IntelliJ 9 (IU-94.273) + TeamCity        Enterprise Version 4.5 (build 8944)

I cannot get TeamCity IDEA plugin to work. I got message:
TeamCity plugin version is not compatible with the server.
Server version is 8944, plugin version is 9140, download updated version of plugin?

I press OK and after restart IDEA got error:
java.lang.NoClassDefFoundError: com/intellij/coverage/CoverageDataManager
From this point only way to get IDEA to work is disable the TeamCity plugin

What can I do in this situation? We do not plan to upgrade to TeamCity 5 at this time.

Thanks
Sergey

0
Comment actions Permalink

To work in IntelliJ 9 you will need at least  TeamCity version 4.5.6.

0

Please sign in to leave a comment.