NUnit report watcher issue on 5.1 EAP (build 13130)

I am trying to get a build to import a custom xml file in the NUnit format, but I always get a message saying "no files found".
I have also tried with an NUnit file generated from another build that is using NUnit ( that build has no problems displaying the NUnit test results ).

I have tried to configure the XML Report Processing section of my NAnt build runner with NUnit and Report path set to "results/*.xml"
I have also tried to echo the importData message from my NAnt script.  I have setup a small example in NAnt to take an existing NUnit report and my custom NUnit report and copy that
into a directory called results in the build checkout.  I issue the importData echo in my NAnt script and I also have the configuration setup to watch the results directory.
I have tried both methods on their own without success also.  You can see that the NUnit report watcher finds the initial reports from the last run, but doesn't find them at the end.
Please advise what I am doing wrong or if this is a bug.

Running build: 5.1 EAP (build 13130)
[18:08:08]: NUnit report watcher

[18:08:08]: [NUnit report watcher] Watching paths:

[18:08:08]: [NUnit report watcher] C:\BuildAgent\work\bfd418414d7e447f\results\*.xml

[18:08:08]: NUnit report watcher

[18:08:08]: [NUnit report watcher] Found existing files:

[18:08:08]: [NUnit report watcher] C:\BuildAgent\work\bfd418414d7e447f\results\report1.xml

[18:08:08]: [NUnit report watcher] C:\BuildAgent\work\bfd418414d7e447f\results\nunittest.xml

[18:08:08]: Starting build process in C:\BuildAgent\work\bfd418414d7e447f

[18:08:09]: Buildfile: file:///C:/BuildAgent/work/bfd418414d7e447f/build2804394637499526045.tmp

[18:08:09]: Target framework: Microsoft .NET Framework 2.0

[18:08:09]: Base Directory: C:\BuildAgent\work\bfd418414d7e447f.

[18:08:09]: Target(s) specified: build

[18:08:09]: Build sequence for target `build' is build

[18:08:09]: Complete build sequence is build

[18:08:09]: build

[18:08:09]: [build] ##teamcity[importData type='nunit' path='C:\BuildAgent\work\bfd418414d7e447f/results/*.xml']

[18:08:09]: [build] copy

[18:08:09]: [copy] Copying 2 files to 'C:\BuildAgent\work\bfd418414d7e447f\results'.

[18:08:09]: [copy] Copying 'C:\BuildAgent\work\bfd418414d7e447f\report1.xml' to 'C:\BuildAgent\work\bfd418414d7e447f\results\report1.xml'.

[18:08:09]: [copy] Copying 'C:\BuildAgent\work\bfd418414d7e447f\nunittest.xml' to 'C:\BuildAgent\work\bfd418414d7e447f\results\nunittest.xml'.

[18:08:10]: Importing data from 'C:\BuildAgent\work\bfd418414d7e447f/results/*.xml' with 'nunit' processor

[18:08:10]: NUnit report watcher

[18:08:10]: [NUnit report watcher] Watching paths: <no paths>

[18:08:10]: Process exit code: 0

[18:08:10]: Waiting for 1 service processes to complete

[18:08:10]: NUnit report watcher

[18:08:10]: [NUnit report watcher] no files found

[18:08:10]: [NUnit report watcher] C:\BuildAgent\work\bfd418414d7e447f\results\*.xml: no files found

[18:08:12]: Build finished
Comment actions Permalink

Could you please attach sample xml produces from your NUnit

What was the version of NUnit?

Please have a look to TeamCity addin for NUnit at


Comment actions Permalink


I issue the importData echo in my NAnt script and I also have the configuration setup to watch the results directory.

Please  avoid setting up some folder monitoring twice (from UI and using service  message). This feature should only be used if you want the plugin to  process several report types - in this case you configure one report  type in the UI and the other type by sending service message.

Please note, that the watcher considers only the files updated since the build start (this  is determined by last modification file timestamp). If you files are copied, but not created during the build they wil be reported as existing and keep off parsing.

If in your case it's necessary to process such files add the following parameter to the importData message: parseOutOfDate='true'

Comment actions Permalink

Victory, Adding parseOutOfDate='true' fixed this issue for me.  Thanks for your help.


Please sign in to leave a comment.