Unable to load DLL 'OraOps9.dll': The specified module could not be found.

Hi Everyone,

I have the following error when I am trying to run my solution:
Test(s) failed. System.DllNotFoundException : Unable to load DLL 'OraOps9.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
   at Oracle.DataAccess.Client.OpsTrace.GetRegTraceInfo(UInt32& TrcLevel)
   at Oracle.DataAccess.Client.OraTrace.GetRegistryTraceInfo()
   at Oracle.DataAccess.Client.OracleConnection..ctor(String connectionString)

I am trying to run test case using nunit on a server pc through teamcity.
I am using XP pro sp3 and whenever I try to build the solution through teamcity I get the error above.
I need to mention that the solution is running/building fine if I run it manually using visual studio 5 and nunit 2.4.8

I have tried changing the security setting on the oracle folder and it didn't help.

As this is a bottle neck error I am stuck....so if anyone has any ideas or solution I will be please to hear them!

cheers
Theo

1 comment

Could you please check mentioned .dll files are available on the build agent machine either near the test assemblies or on GAC.
Please check build agent is running under some real administrative account.

Thanks!

0

Please sign in to leave a comment.