TC 5.0.3 maven/svn problem

Hi,

I configured Maven build from svn repository and it worked fine until site goal was added to configuration: during site report generation Maven fails to get access to svn logs, see extract from the build log:

[17:02:59]: [INFO] Executing: svn --non-interactive log -v -r "{2010-02-21 14:02:59 +0000}:{2010-03-24 14:02:59 +0000}"https://gm-debt-risk-architecture.ibitdev.com/svn/gm-debt-risk-architecture/debt-risk-framework/trunk/debt-risk-framework

[17:02:59]: [INFO] Working directory: C:\TeamCity\buildAgent\work\776ba67ac87101d0[17:03:23]: [ERROR] Provider message:

[17:03:23]: [ERROR] The svn command failed.

[17:03:23]: [ERROR] Command output:

[17:03:23]: [ERROR] svn: OPTIONS of 'https://gm-debt-risk-architecture.ibitdev.com/svn/gm-debt-risk-architecture/debt-risk-framework/trunk/debt-risk-framework': could not connect to server (https://gm-debt-risk-architecture.ibitdev.com)

[17:03:23]: [INFO] ------------------------------------------------------------------------

[17:03:23]: [ERROR] BUILD ERROR

[17:03:23]: [INFO] ------------------------------------------------------------------------

[17:03:23]: [INFO] Error during page generation

[17:03:23]: Embedded error: Error rendering Maven report: An error has occurred during changelog command :

[17:03:23]: Command failed.

12 comments

Hello,

Do you use the checkout on agent mode?

0

I did try both - on server and on agent modes - result the same.

0

Please switch to checkout on agent, run a build, and then try to execute the same command manually in the same directory under the same user your agent runs under. Will the result be the same?

0

Currently it is in on-agent mode and already tried this very command under same user, command output was ok as expected. My svn server is behind firewall and I use proxy defined in Subversion/servers file. My vcs configuration contains link to this file. Is it possible that Maven process running on agent doesn't have access to this setting and for some reason can't find it on disk? My local  path to svn configs is different from the default one used in TC.

0

Just to be absolutely sure. Did you try this in the same directory where teamcity builds run? This may be improtant, and you didn't mention.

0

yes, agents dir is c:\TeamCity\buildAgent\work, i created temp dir named ttt inside and run the command.

0

No, Danila. I'm talking about the directory where the sources are checked out by TeamCity. You can find the exact path in the top of the build log.

0

One more suggestion: I installed TC under system account, while svn config is under user account. If nothing special were done to handle the config from Maven it will be missed.

0

Agent dir containing source from last build is c:\TeamCity\buildAgent\work\f60c9a898c0c57e0. In this very dir svn command work out fine.

0

If you mean that the agent is running under the system account, this definitely indicates that your manual command is launched under a different environment comparing to the agent. This explaines the difference in the results. Try running the agent under the user account.

0

Unfortunately my user doesn't have rights to start such process. The only option I had was to provide svn user/password as part of scm url inside pom.xml. I believe this is wrong way to do provided svn credentials are configured as part of TC vcs root. Would you create corresponding change request? Or at least add notice in documentation.

0

I agree providing credentials in the scm url is a bad practice.

Is it possible to configure a separate user account solely dedicated for running the teamcity agent? You can reinstall the agent to be run from this account having all necessary configs (scm, maven, etc.). This helps to avoid many problems related to the system account. see http://confluence.jetbrains.net/display/TCD5/Known+Issues#KnownIssues-AgentrunningasWindowsServiceLimitations

0

Please sign in to leave a comment.