This is an autogenerated index file (there was no index.html found in the generated report) with NCover 3

Hi,

What is the recommended setup for TeamCity (5.0.3) with NCover 3 code coverage reporting integration?  With the current settings, I am getting the following artifacts outputted from the build:

+ teamcity
  + .NETCoverage
      CoverageReport.xml 13.41mb
  coverage.zip 587b

coverage.zip just contains an index.html with the message This is an autogenerated index file (there was no index.html found in the generated report)

Do I need any NCover arguments configured?  Do I need any artifact paths setup?

TIA.

6 comments

Hello,

index.html file is generated if there was not index.html file generated by the NCover3 report generator.
Please try to specify: //or FullCoverageReport:Html:{teamcity.report.path} for NCover reporting arguments
and //ias .* for NCover Arguments.


Thanks!

0

I get this same issue!! I have set these properties as you have suggested but I still get the auto generated index.html file.

I have attached my log file and a screen shot of my configuration UI.

Help with this would be appreciated.



Attachment(s):
CropperCapture[13].png
Client_Portal_Nightly_0.1.27.9933.log.zip
0

Does  generated index.html file contains links to NCover generated report? Please have a look the previous my commend with an explanation of the generation of index.html by TeamCity.

What would you expect to see instead?

0

The generated index file contains nothing other than the the html for the subject line (I have attached the coverage.zip atrifact file the teamcity creates).

What I would expect to see is the Html coverage reports that I would get when I run ncover directly.

I would expect results as mentioned in your colleagues blog: http://blogs.jetbrains.com/teamcity/2010/02/19/net-code-coverage-in-two-clicks/

When I click on the 'View full report' link or the 'Code Covergae Tab' I see the 'This is an autogenerated index file (there was no index.html found in the generated report) with NCover 3' message when I expected to see the full report html or the SymbolModule report.

0

You have missed //or in the coverage reporter parameters.

You may start NCover.Reporter.Console.exe /? to find more information on reporting arguments.

0

Thanks Eugene,

I think the 'or' part threw me off as I stupidly assumed it was 'this or that' rather than the whole line being the command line switch.

0

Please sign in to leave a comment.