5.1 NAnt runner error on LINUX after upgrade

After the upgrade from 5.1 EAP to 5.1 RTM I am now getting the following exception on my Linux box (  Linux, version 2.6.29.4-167.fc11.x86_64 ) with the NAnt runner:

[14:47:53]: IllegalStateException when running build stage CallRunnerStage: @NotNull method jetbrains/buildServer/agent/nant/NAntLocator.getNAntExe must not return null

[14:47:53]: java.lang.IllegalStateException: @NotNull method jetbrains/buildServer/agent/nant/NAntLocator.getNAntExe must not return null
                java.lang.IllegalStateException: @NotNull method jetbrains/buildServer/agent/nant/NAntLocator.getNAntExe must not return null
                     at jetbrains.buildServer.agent.nant.NAntLocator.getNAntExe(NAntLocator.java:38)
                     at jetbrains.buildServer.agent.nant.NAntBuildService.getNAntExe(NAntBuildService.java:64)
                     at jetbrains.buildServer.agent.nant.NAntBuildService.makeProgramCommandLine(NAntBuildService.java:57)
                    at jetbrains.buildServer.agent.runner2.GenericCommandLineBuildProcess.start(GenericCommandLineBuildProcess.java:58)
                     at jetbrains.buildServer.agent.impl.runStages.CallRunnerStage.doBuildStage(CallRunnerStage.java:39)
                     at jetbrains.buildServer.agent.impl.BuildRunAction.callRunStage(BuildRunAction.java:115)
                     at jetbrains.buildServer.agent.impl.BuildRunAction.doStages(BuildRunAction.java:77)
                     at jetbrains.buildServer.agent.impl.BuildRunAction.access$000(BuildRunAction.java:17)
                     at jetbrains.buildServer.agent.impl.BuildRunAction$1.run(BuildRunAction.java:53)
      at java.lang.Thread.run(Thread.java:636)


On the agent I have the following set:
NAntHome

/SomeMount/ThirdPartyTools/nant-0.85



I verified that I could login on the agent and launch the NAnt.exe at the location specified by NAntHome.  I target mono-2.0 for NAnt.  My builds running on Windows that use NAnt are not having any issues.

From the console on the Linux build agent:

[user~]$ mono /SomeMount/ThirdPartyTools/nant-0.85/bin/NAnt.exe -help
NAnt 0.85 (Build 0.85.2478.0; release; 10/14/2006)
Copyright (C) 2001-2006 Gerry Shaw
http://nant.sourceforge.net



Anybody know how to fix this?
thanks for the help,
NS

Please sign in to leave a comment.