Possible to turn off properties passed to Ant Build Runner from Team City?

I have a BlackBerry project that I build with Ant (using bb-ant-tools). It works when I run it from the command line.

It doesn't build for me when I run it in TeamCity. The build fails inside the rapc task. I ran it again with the -debug switch to see where it's actually failing. The actual command line passed to java.exe is massive and contains tons of extra properties that I don't use in the build file, including MSBuild-related properties. My theory on why it's failing are all the unquoted strings within the command line arguments.

It works when I call Ant through the Command Line Runner. I'd prefer not to do this, though, since there are things I'd like to add to the TeamCity config once I have the basic build running.

So my question: can I turn off those properties getting passed to Ant?

5 comments

What is the error message you get from the build when it started by TeamCity? Could you please provide build log with -debug parameter?

0

Attached are a log from the TeamCity build with -debug set (named TeamCity_BB_Client_CI_11.log) and a log from an ant command line build on the same directory (named commandlinebuild.log).

I forgot to mention I'm using the latest TeamCity, downloaded and installed yesterday. I've used TeamCity elsewhere for building BlackBerry projects and it's worked flawlessly.



Attachment(s):
commandlinebuild.log.zip
TeamCity_BB_Client_CI_11.log.zip
0

So far it looks like <rapc/> task which starts separate process can't correctly process arguments with spaces. I will try to reproduce this locally. As a workaround, try to start Ant from the command line runner.

0

It is indeed a bug in RapcTask. I've submitted it to their tracker: https://sourceforge.net/tracker/?func=detail&aid=2997162&group_id=195339&atid=953046

I also patched the task so that it worked correctly in this case, attached is a jar with this task fixed, please try it. At least it works in my case.



Attachment(s):
bb-ant-tools.jar
0

Pavel,

That's going above and beyond the call of duty.

Thanks so much!

0

Please sign in to leave a comment.