Can not make EC2 agent register

I have a local team city server (5.1.1 build 13398) that we've put in our DMZ and is accessible from my AMI via HTTPS.  We've created a certificate and successfully imported it as stated in the documentation for setting up HTTPS.

In the server configuration I have the same address I've exposed setup (exactly like I can run it via IE).  I am using the default port on the agent (9090).  I have a security group setup exposing that port:

Security group.jpg
My teamcity-server.log says:

[2010-05-06 09:10:07,059]   WARN - rverSide.impl.XmlRpcBasedAgent - Agent 'ip-0AD46D7D' cannot be accessed by any of the addresses: [184.73.27.226, 10.194.75.36], port 9090. Check firewall and/or try to specify 'ownAddress' in agent configuration.

I did see a post that indicated I should be able to put my external IP into a http request like:

http://174.129.167.196:9090/RPC2

and get something back.  I can not.  What in the world do I have wrong?  My cloud log looks great...  

Why is the documentation for setting this up so sorely lacking?

3 comments

I see a posting http://www.jetbrains.net/devnet/message/5253309#5253309 from someone doing the same thing I'm trying, however I can't make my agent be recognized as connected.  It just shows up on the cloud tab.  At this point I don't even have an idea what I can try next...

0

Robert,

For now this seems to be related to agent-server connectivity and not related to TeamCity EC2 integraiton. You can proabbly try to start instance of the AMI from EC2 console and try to investigate the issue having access to the agent machine.

Basically, you need to check that the agent is accessible from the server (as noted in our doc see Network section).

Please doublecheck the network and machine settings. You should be able to open http://address:9090/RPC2 in the browser on the machine running the server and get something like "Method GET not implemented (try POST)" in response.

Where "address" is one of the addresses listed in "cannot be accessed by any of the addresses:" message.

If you are able to open the address on the agent machine and not able to do it on the server thatn you should fix the networking issue - this is probably not related to TeamCity.

0

I had opened the port in the Security Group but had forgotten Windows Firewall.  Once I did that, I was able to open http://address:9090/RPC2 on it (the actual error in IE is a 404, the web page can not be found, as opposed to a connection error).  I still have an issue from our TC Server because the outbound port is closed but that is a problem for my IT department.  I believe this is my last obstacle.

Thanks!

0

Please sign in to leave a comment.