Cannot do remote run in VS 2010

Hi

We just upgraded to VS 2010 and now we cannot do a remote run from within VS 2010 due to the following exception:

Message = “Could not load type 'Microsoft.TeamFoundation.Client.TeamFoundationServerBase' from assembly 'Microsoft.TeamFoundation.Client, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.”
ExceptionPath = Root.InnerException
ClassName = System.TypeLoadException
HResult = COR_E_TYPELOAD=80131522
Source = JetBrains.TeamCity.VSTS.10.0
TypeLoadClassName = Microsoft.TeamFoundation.Client.TeamFoundationServerBase
TypeLoadAssemblyName = “Microsoft.TeamFoundation.Client, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a”
TypeLoadResourceID = -2146233054
StackTraceString = “ at JetBrains.TeamCity.VSTS.UI.WorkItems.WorkItemsControl.InitializeUI(IEnumerable`1 targetProjectNames)
at JetBrains.TeamCity.VSTS.UI.TFSCommitPageUI.<>c__DisplayClass8.<InitializeUnderProgress>b__3() in  c:\BuildAgent\work\d1af9838e4bfdc89\src\TeamCity.VSTS\src\UI\TFSCommitPageUI.cs:line 77
at JetBrains.TeamCity.RemoteRun.PersonalBuild.Configuration.PersonalBuildConfigurationForm.<>c__DisplayClass1d.<InitializeCustomDelayedCommitUI>b__1a(VoidDelegate action) in c:\BuildAgent\work\d1af9838e4bfdc89\src\TeamCity.RemoteRun\src\PersonalBuild\Configuration\PersonalBuildConfigurationForm.cs:line 165
at JetBrains.TeamCity.VSTS.UI.TFSCommitPageUI.InitializeUnderProgress(IProgressIndicator pi, DoUnderUIAndWait ui, DoAfterProgressBarShown after) in c:\BuildAgent\work\d1af9838e4bfdc89\src\TeamCity.VSTS\src\UI\TFSCommitPageUI.cs:line 77
at JetBrains.TeamCity.RemoteRun.PersonalBuild.Configuration.PersonalBuildConfigurationForm.<>c__DisplayClass1d.<InitializeCustomDelayedCommitUI>b__19(IProgressIndicator progress) in c:\BuildAgent\work\d1af9838e4bfdc89\src\TeamCity.RemoteRun\src\PersonalBuild\Configuration\PersonalBuildConfigurationForm.cs:line 165
at JetBrains.UI.Application.Progress.UITaskExecutorRun.RunStartTaskCallTaskAction() in c:\BuildAgent\work\d1af9838e4bfdc89\Platform\src\UI\src\Shell\Progress\UITaskExecutorRun.cs:line 274



I've logged the issue here.  Anybody any ideas on how to get the remote run working again?  We desperately need this to work again.  We are running TeamCity Professional 5.1.1 (build 13398)

1 comment

Hi, Carel. This issue was alredy fixed. Fix would be avaliable in TC 5.1.2.
However, this exception is not prevents you from sending Remote Run. It only affects you, if you want to assotiate your commit with TFS work item.

0

Please sign in to leave a comment.