Jabber Notifier

Is it possible to disable the Jabber notifier? The settings are required, so I put some dummy values in there. I did notice that the logs would mention connection failures with previous versions, but with 5.1 I am now getting this error at the top of the TeamCity window:

Failed to send jabber notification: Could not connect to a:0.

8 comments

Hello,

  In TeamCity 5.1 (but not in earlier versions), you can

  • Stop server
  • remove TeamCity/webapps/ROOT/WEB-INF/plugins/jabber directory
  • Start server


  You won't see jabber settings anymore.

  HTH,
  KIR

0

Will this change be overwritten with the next update to TeamCity?

0

Hi,

  Yes, if you upgrade TeamCity you would have to do it again.
  Unfortunately, we don't have a possibility to disable a TeamCity plugin.

  You may also want to vote for http://youtrack.jetbrains.net/issue/TW-11831 and http://youtrack.jetbrains.net/issue/TW-11562

  Regards,
  KIR

0

I removed the configuration settings by manually editing the XML file so I don't get the error in TeamCity GUI anymore.

I am wondering, though, why there is no configuration option to turn off the Jabber notifier (or any notifier)? At the very least, an empty server name could serve the same purpose. That doesn't mean disabling the entire plugin, just a config option to stop it from trying to send notifications. Not everyone has a Jabber message server. We do, but we don't use it for build notifications. Maybe we will in the future; at which point I would have been mildly irritated if I had deleted the plugin.

Anyway, as long as its an internal error and isn't throwing up errors in the GUI, it doesn't matter too much to me. It just seems strange, but it's probably just because I don't understand the inner workings of TeamCity.

0

+1 for this.
I'm going to have to disable it tonight.

0

For some reason I am getting an error message in the GUI now, I just started seeing this after running 5.1 since it got released

Failed to send jabber notification: Could not connect to jabber.some.domain:5222. Shows up at the top of the page.

+1 here also


-NS

0

EDIT:  Nevermind. Although it still needs to be documented appropriately, I see now that this feature comes with version 5.1.2, which I do not have installed quite yet.

http://youtrack.jetbrains.net/issue/TW-11831 appears to be fixed with an indication that we can now "pause" jabber notifications in order to fix this.  I've deleted the group notifications but I still get an error at the top of the page. Does anyone have actual documentation/instructions on how to pause jabber notifications so we can get rid of the warning at the top of the page?  Thanks.

0

Hi Dave,

This feature is not documented yet. To pause jabber or email notifier please go to "Administration" -> "Server Configuration" -> "Jabber Notifier" (or Email), check "Pause notifier" and save the setting.
No notifications will be sent after that.


---
Maxim

0

Please sign in to leave a comment.