FxCop problem - not able to find dll's

Hi,

I must have something wrong with my configuration, I have the following project setup:

one configuration - checkouts the source, build solution with sln2008 runner, creates artifacts (dlls) - this work fine
second configuration - no source checkout, FxCop Runner, triggered by last build of the first configuration, snapshot&artifact dependancy (all the dlls, they are matched and copied correctly), but I get always:

[12:14:33]: * Could not load file: '**/*.dll'.
[12:14:33]: * Analysis was not performed; at least one valid rules assembly and one valid
[12:14:33]: target file must be specified.
[12:14:33]: * 1 total analysis engine exceptions.
[12:14:33]: Process exited with code 9

I tried to use several assembly paths in FxCop options, but still no luck - can you please help how to configure the assembly path correctly?

btw: I have to put login and Server URL into TeamCity VS addin each time I start Visual Studio (even remember me is checked), do you experience the same behavior?

thanks
tom
8 comments
Comment actions Permalink

ops, I've just found the issue - FxCop doesn't accept the ant style paths + I didn't use the directory name to which the artifacts were downloaded...

IMHO it would really make sense to have to possibility of multiple runners...

+ one tiny enhancement: the Assemblies text box in FxCop configuration would be text area


thanks
tom

0
Comment actions Permalink

tkapp wrote:
+ one tiny enhancement: the Assemblies text box in FxCop configuration would be text area

Ok. I opened an issue: http://jetbrains.net/tracker/issue/TW-6715

0
Comment actions Permalink

when FxCop "target file must be specified" issue is expected to be fixed? i'm having the same error after upgrate from TeamCity 4.x (don't remember exact version number) to 5.0.3.

in the log file i see that assembly names are not passed as FxCop parameters (ppt_FxCop_7.log).
although just before upgrade to v. 5.0.3 the same configuration worked ok (ppt_FxCop_5.log)



Attachment(s):
ppt_FxCop_5.log.zip
ppt_FxCop_7.log.zip
0
Comment actions Permalink

Unfortunately, there is a bug in 5.0: http://youtrack.jetbrains.net/issue/TW-10465, it was fixed in 5.1 (not released yet).

As temporary workaround could you please check you pattern as FxCop plugin does case-sensitive match of file names.

0
Comment actions Permalink

thank you for the reply. i've found useful solution already. as a workaround i've specified missing arguments in "Additional FxCopCmd options" field (as "/f:C:\tsProjects\ppt\Src\PPT\bin\ppt*.dll").

0
Comment actions Permalink

unfortunately, FxCop runner is still not able to find dll's:


[15:45:09]: bt3
[15:45:09]: Checking for changes
[15:45:10]: Clearing temporary directory: C:\TeamCity\buildAgent\temp\buildTmp
[15:45:10]: Checkout directory: C:\TeamCity\buildAgent\work\27f84e3eca3a33d5
[15:45:10]: Updating sources: server side checkout...
[15:45:10]:  [Updating sources: server side checkout...] Repository sources transferred
[15:45:10]: Running FxCop
[15:45:10]: Matched assembly files:
[15:45:10]:   none
[15:45:10]: RunBuildException when running build stage CallRunnerStage: No files matched the pattern
[15:45:10]: Build finished


i've tried paths enclosed/not enclosed with quotes. failed. workaround that worked on previous versions (additional parameter "/f .... ") works no more .{

ps: TeamCity Professional 5.1.2 (build 13430)
0
Comment actions Permalink

Sorry, I mistook you issue with another one.
Correct one: http://youtrack.jetbrains.net/issue/TW-12434

Now the tip below "Assemblies" text area is "Assembly file names relative to checkout root",
no absolute paths allowed yet.

0
Comment actions Permalink

thank you.
resume:
1. checkout directory should be set (even if no actual checkout is needed)
2. assembly paths should be specified using relative paths to checkout directory (absolute paths are not allowed)

0

Please sign in to leave a comment.