Clearcase VCS - Cannot add branch

Team City 4.5.5
As regular readers of this forum may know we have lots of problems with the integration with clearcase. But they are normally fixable. Today we started to get the following error on builds. Normally it would be a clearcase error that TC reacts to and replacing the view or killing an update that has not finished will fix it. But in the error below, clearcase is not mentioned. And why is TC messing about with, I guess, the config spec?

java.util.concurrent.ExecutionException: jetbrains.buildServer.vcs.VcsException: Problem collecting changes for 'CuPID 2009.10 :: CuPID Buddy Build' : Error collecting changes for VCS root 'clearcase: D:\TeamCity\SnapViews\CupidRestate_2009.10\conman_VOB' #4
jetbrains.buildServer.vcs.VcsException: Cannot add branch CupidRestate_2009.10 to level main

Nothing has changed from yesterday - new files have been added and changed. But these would be compile problems, not getting changes problems.
Anyway, I just decided to delete the existing snapshot view and replace with same view root. And the result is exactly the same.

So does anyone know what causes a TC error of "cannot add branch ..."?

Regards,
John

2 comments

Anyone with any ideas on this. Have replaced views. Still get exactly the same error.
Fortunately it is not a complete stopper as we have set up a Hudson system which is working well but we are supposed to be using TeamCity so it would be useful to have a solution.

0

Hi,

Sorry for delay in replying.

Can you please provide me your debug logs with this error?

0

Please sign in to leave a comment.