VS2008 Build failing with NUnitLauncher.exe error

Hi,

I have a build from a VS2008 solution, using nUnit 2.5.5 and no coverage tool. It's failing with error :

C:\TeamCity\buildAgent\work\f62ee4715c28e0d0\MarketMerger.sln.teamcity.patch.tcprojx(17,5): error : c:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe "@@" C:\TeamCity\buildAgent\temp\buildTmp\tmp80C.tmp exited with code -1073741819.

Not sure how to investigate this, anyone know what this error means?

Thanks

10 comments

Anyone know anything about this? I have tried all combinations of unit test options, but can't fix this error.

0

Does nobody even know what arguments nUnitLauncher.exe are expects? I presume @@ isn't one of them, but I don't know how to find out what went wrong. I can't believe that I am getting a total showstopper on my build server and there is no documentation about it anywhere.

0

Please attach a screebshot of the build runner settings. This error could arise is you start NUnit in bitness of .NET framework version that is not available on the build agent machine. you may add 'teamcity.agent.dotnet.debug' to make NUnitLauncher.exe running verbose mode.

0

Hi Eugene,

Thanks for your reply. Here's a screenshot. .NET 4 and nUnit 2.5.5 are definitely on the build machine. Where do I add the debug flag too? Which input field?teamcity_screenshot.JPG

0

Select 6. Properties and environment variables and put this as environment variable.
Build log will contain more information afterwards

0

Like this ? I still get the same level of output.
teamcity_screenshot_verbose.bmp

[18:25:35]: (TeamCity_Generated_NUnitTests target) ->
[18:25:35]: C:\TeamCity\buildAgent\work\de94992ab3e79d2f\*****.sln.teamcity.patch.tcprojx(17,5): error : c:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe "@@" C:\TeamCity\buildAgent\temp\buildTmp\tmp24C.tmp exited with code -1073741819.
[
0

I have just noticed that the server with TeamCity on it has .Net 4.0 Client profile rather than the full framework. Is this likely to cause a problem launching NUnitLauncher? (Our .Net 4 projects build  successfully, just nUnit tests are not launched)

0

We use the following configuration to make .NET process start under .NET 4:

<configuration>
    <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0.30319"/>
        <supportedRuntime version="v4.0.30128"/>
        <supportedRuntime version="v4.0.21006"/>
        <supportedRuntime version="v4.0.20506"/>

        <supportedRuntime version="v4.0"/>
    </startup>
  <runtime>
    <!-- Don't kill application on first uncaught exception. -->
    <legacyUnhandledExceptionPolicy enabled="1" />
  </runtime>
</configuration>



Does this config looks right to run under .NET 4 client profile?

You may patch this config in the following files:
- <server>/webapps/ROOT/update/plugins/dotnetPlugin.zip!/dotnetPlugin/bin/JetBrains.TeamCity.PlatformProcessRunner.v4.0.*.exe.config

Thanks!
0

Hi Eugene,

Thanks for that. The config files already have all those entries. Our version of .Net Client profile is v4.0.30319, so I presume the config should be able to handle this. So, still no idea why the unit tests don't launch.

0

Will it work if you install .NET 4.0 full?

Please check all dependiencies of tests assemblies are available on the build agent machine.

0

Please sign in to leave a comment.