installation of TeamCity 5.1.3 hangs while stopping agentd on clean machine which has no previous installation

I'm trying to install TeamCity 5.1.3 (released 1 week ago), on a Windows Server 2003 machine.  The machine hasn't had TeamCity installed on it before, but it seems to have hung while stopping the agentd.

It's just stuck on
"please wait while jetbrains teamcity is being installed"
and
"output folder g:\mydir\teamcity\buildagent\bin"

I can see the install process has put something in
F:\Documents and Settings\john doe\Local Settings\Temp\5

and is trying to run that file as a child process doing a
agentd -stop

Is it supposed to be trying to stop the agentd?!  Or should I not worry about this?

I checked the permissions on the folder it's installing to, and they look fine.

I managed to install 5.1.2 on a different machine last week and that was fine.

8 comments

I tried 5.1.2 to see if the problem had only recently been introduced.

But the installation still gets stuck.  I can see there is a child process of the installer process, but I don't think this child process is actually doing anything

Child process command line:
"F:\DOCUME~1\JONDOE~1\LOCALS~1\Temp\5\nstB.tmp\nsC.tmp" "g:\mydir\TeamCity\buildAgent\bin\agentd.exe" -stop

I also tried 5.0.3 - same behaviour.  I guess this is to do with this machine, rather than a particular version TeamCity! :)  But any assistance / where to look next etc., would be most appreciated.

0

I have managed to work around this.

I tried installing 5.1.3 again, but this time running as a different user.  The installation was successful.

I'm still not clear as to why it didn't work running as the original user.  The second user has, if anything, fewer permissions.  It's local (cf. a domain account), and doesn't have Administrator privileges.

Just for next time, I'd be interested to know what's going on, is this a bug etc.

0

Hello Jon,

Since 2.x versions There is no more agentd.exe in the new agent installation. To migrate to the new service wrapper you should reinstall agent explicitly.

To upgrade agent from agentd service to java service wrapper:

  • Uninstall agent      
    • use uninstaller/add remove programs
    • ensure agent service is stopped
    • ensure there is no agentd.exe and old build agent service installed in the system
  • Install new agent using any distribution you like (zip, java web start, windows installer)


Kind regards,
Marina

0

Hi Marina,

Thanks for your reply.  However I'm still a bit confused...

I wasn't trying to upgrade anything, and I wasn't trying to do anything that explicitly required knowledge of agents or agentd.  All I did was download various windows 5.x.x exe installers to a machine that has never seen TeamCity before, and try to run them, typically clicking yes/ok/next at each stage.  So it's a fairly out-of-the-box, new user kind of scenario.

I just noticed that the install had hung, and could see it was running a process doing an 'agentd -stop'.  This wasn't anything I had invoked directly, just what I noticed the installer processes were doing.

I don't think this server machine existed in the days of TeamCity 1.x or 2.x... and it certainly doesn't have any mention of TeamCity in add/remove programs.

Is there any other service that could fool the TeamCity installer into thinking that an old agentd was installed?  Some other service running on a default port?  Or another service similarly named?

Thanks
Jon

0

Jon,

Could you please check does file agentd.exe exist on machine? Please attach if you find it.

Thanks,
Marina

0

From my second post above, the child process command line is always something like:
"F:\DOCUME~1\JONDOE~1\LOCALS~1\Temp\5\nstB.tmp\nsC.tmp"  "g:\mydir\TeamCity\buildAgent\bin\agentd.exe" -stop

But because this is a clean install, no files exist in g:\mydir\TeamCity\buildAgent.  It's as if the build gets as far as creating TeamCity and the directory buildAgent under it.  Then tries to run the "agentd -stop" but agentd doesn't exist.

Why does it think there's an existing installation there?!

0

TeamCity installer tries to run agentd.exe process to make sure there is no ancient agentd.exe service installed for old build agent. For your case this call should have simply failed, because agentd.exe had not existed. This failure is caught by the installer and is normally handled. It is strange that you notices some *.tmp process that was started with a commandline to agentd.exe.

Do you have any antivirus running on the machine? If yes, please try running the installer with antivirus disabled.

0

Thanks for your reply Eugene.  It's a bit of a story to get the OK to turn off anti-virus on this machine.  And I have managed to work around the problem by running the install as a different user.

I think it's a good theory that it could be the anti-virus.  I mainly wanted to solve the problem so I know what to do next time... and you have now got me that far - I'll make sure I turn off anti-virus first if I see the problem again.  Thanks.

0

Please sign in to leave a comment.