Does TC 5.1.2 (build 13430) use platform setting when compiling msbuild files?

Im new to both TeamCity and MSBuild and ive managed to get a regular solution runner building a vs2005 project up and running ok but ive now got to get a VS2010 msbuild runner going.

I have the build file and it works when run with VS command line: msbuild /property:Configuration=Release;Platform=x86 ChangeBuild.proj

But when i setup TC to use this script it seems to be ignoring the platform setting of x86 in the runner config page as i get;

[13:01:23]: Build started 7/28/2010 1:01:22 PM.
[13:01:23]: Project "c:\companyx\dev\clisp2010\clisp\clisp.studio\ChangeBuild.proj.teamcity.patch.tcprojx" on node 1 (Release target(s)).
[13:01:23]: c:\companyx\dev\clisp2010\clisp\clisp.studio\ChangeBuild.proj.teamcity.patch.tcprojx : error MSB4057: The target "Release" does not exist in the project
[13:01:23]: Done Building Project "c:\companyx\dev\clisp2010\clisp\clisp.studio\ChangeBuild.proj.teamcity.patch.tcprojx" (Release target(s)) -- FAILED.
[13:01:23]: Build FAILED.
[13:01:23]: "c:\companyx\dev\clisp2010\clisp\clisp.studio\ChangeBuild.proj.teamcity.patch.tcprojx" (Release target) (1) ->
[13:01:23]: c:\companyx\dev\clisp2010\clisp\clisp.studio\ChangeBuild.proj.teamcity.patch.tcprojx : error MSB4057: The target "Release" does not exist in the project.
[13:01:23]: 0 Warning(s)
[13:01:23]: 1 Error(s)
[13:01:23]: Time Elapsed 00:00:00.59
The build runner is setup to use MSBuild Version 4.0, Build Tools Version 4.0, Run Platform x86, Target Release.
But i had to use "/property:Configuration=Release;Platform=x86" as command line parameters to get it to get this far without error.
Does this mean i have to change to command line runner and specify the /property param or is there something i can put in my msbuild script that will satisfy this requirement.
As a side note, the build script doesnt work from command line unless i specify a platform, i get this the same error as TC which suggests TC is not using this setting when building the MSBuild file prior to exeuting it.
Any help would be greatly appreciated
2 comments

You may define msbuild properties in 6. Properties and Environment variables tab of build configuration settings. Please try removing custom commandline arguments by using it.
Have you specified ToolsVersion in your .proj file? Please check it is specified and set to 4.0

0

removing the command line params seems to have resolved this, though the reason i had them was because it wasnt building in the first place.. oh well thanks this seems to be fixed.

0

Please sign in to leave a comment.