Problem with Visual Studio plugin TFS "Failed to collect changes"

I have successfully installed the vs plugin for remote run in my visual studio IDE. I get the TeamCity meny option and I can log in to my teamcity server ( Version   5.1.2) (build 13430). But when I try to do a remote run I get the following dialog presented:


image1.jpg

When I try to click the "See details" in the  dialog I get an error message.

image2.jpg

This problem only happens on one of our team members computers and all the rest og our team can use the teamCity plugin against out team server and our TFS source control system. The team member can get latest and check in his changes in the team explorer in his visual studio installastion. He is running 64 bit window 7 like the rest of the team. I have read of a simular problem that was registered by lauren Kepme, but this looked to be in regards to suberversion.

Can anyone suggest how to debug this or have any similar experience?
14 comments

Please attach all log files from  %TEMP%/JetLogs.
Do you use VS2010? Do you have another versions of TeamExplorer installed?

0

I do not have access to my team mebers machine until another 12 hours. Are the logs present in his local machine or is it the log on the team city server that is interersting in this case. On my own local machine (with a working addin) in the jetlog folder i find files that are named similar to : JetBrainsLog.TeamCity.2010-07-06T13-15-09.devenv#7384, is it these logs on my team mebers machine you need? I will extract the logs as soon as I get access to his machine.

We are all using the following version of visual studio 2010
Installed Version: Premium

Microsoft Visual Studio 2010 Team Explorer  


JetBrains ReSharper 5   C# Edition build 5.0.1659.36 on 2010-04-13T02:19:06
JetBrains ReSharper 5 package for Microsoft Visual Studio. For more information about ReSharper, visit http://www.jetbrains.com/resharper/. Copyright © 2003–2010 JetBrains, Inc.

TeamCity Addin for Microsoft(R) Visual Studio(TM)   [build 13430 (5.1.26.0)]
TeamCity integration package for Microsoft Visual Studio. For more information, please visit http://www.jetbrains.com/teamcity.

0

I have attached the logs for the jetlogs folder for the computer where I get the messages displayed in the post. I should also mention that the team member is using Norwegian Window 7 if that could be a problem in his case. But we have others on the team also using norwegian windows 7 and do not have any problems with the plugin.



Attachment(s):
logs.zip
0

I've noticed that TeamCity addin failed to access to
C:\Users\rra\AppData\Local\JetBrains\TeamCity\v5.1\vs10.0\DelayedCommit.Settings.xml

Could there be more than one instance of Visual Studio openned?
Is that possible to try running only one VS to check the issue?

What are the local changes on this machine? According to logs there could be some change without local path.
Try to shelve all changes and check weather it will work. Please attach fill list of changes too.

Thanks!

0

There are only one instance of visual studio 2010 running and the current user does not have any files in the tfs repository checked out.

But when I try to access ther users/rra/appData in windows explorer the folder appData is not present in windows explorer. If i write the path in the explorer address line i fint the folder, but it can not be accessed directly for windows explorer. Any further ideas?

0

Was you logged into as rra? Have you tried it locally? Could there be any security issues? Could there be any security issues with TFS too?

0

I was logged in as rra user. I can chech out and check in files from tfs repository form the team explorer in the same visual studio. I have looked at the

C:\Users\rra\AppData\Local\JetBrains\TeamCity\v5.1\vs10.0\DelayedCommit.Settings.xml file and the rra user has permission to access the file. I have also tried to run visual studio as administrator, but that did not work either.

I have tried to uninstall and reinstall the plugin, but that din not work. Are the entire program removed from the system when i run uninstall, or is there anything else I need to do to remove the addin completley before i try to reinstall?

0

this is the same part from my computer when the error is not present:

08:44:20.689: Thread:31: [LOGIN_LOWLEVEL] Authenticaticated
08:44:20.691: Thread:31: [LOGIN] Logged in
08:44:22.043: Thread:1: [Trace::Write] Entering Initialize() of: Microsoft.VisualStudio.TeamArchitect.DesignersCommon.DesignersCommonPackage
08:44:22.160: Thread:31: Solution key = c:\users\geirp\documents\visual studio 2010\projects\vismasamhandlingarkiv\vismasamhandlingarkiv\$#$c:\users\geirp\documents\visual studio 2010\projects\vismasamhandlingarkiv\vismasamhandlingarkiv\vismasamhandlingarkiv.sln$$##$$c:\users\geirp\documents\visual studio 2010\projects\vismasamhandlingarkiv\vismasamhandlingarkiv\vismasamhandlingarkiv.suo
08:44:22.160: Thread:31: Start loading settings from registry.
08:44:22.160: Thread:31: Settings loaded.
08:44:22.160: Thread:31: Start saving settings from registry.
08:44:22.161: Thread:31: settings saved.

Here is the same part of the log on the rra user machine when he get the error:

11:56:19.793: Thread:36: [LOGIN_LOWLEVEL] Authenticaticated
11:56:19.796: Thread:36: [LOGIN] Logged in
11:56:19.832: Thread:36: Error during deserializing delayed commit cookies from file C:\Users\rra\AppData\Local\JetBrains\TeamCity\v5.1\vs10.0\DelayedCommit.Settings.xml
11:56:19.844: Thread:36: EXCEPTION: The process cannot access the file 'C:\Users\rra\AppData\Local\JetBrains\TeamCity\v5.1\vs10.0\DelayedCommit.Settings.xml' because it is being used by another process.
System.IO.IOException: The process cannot access the file 'C:\Users\rra\AppData\Local\JetBrains\TeamCity\v5.1\vs10.0\DelayedCommit.Settings.xml' because it is being used by another process.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   at JetBrains.TeamCity.Utils.SerializationUtil`1.Deserialize(String file) in c:\Agent\work\d1af9838e4bfdc89\src\TeamCity.Utils\src\SerializationUtil.cs:line 38
   at JetBrains.TeamCity.RemoteRun.DelayedCommit.Impl.DelayedCommitPersistenceNewImpl.LoadDataInternal(String file) in c:\Agent\work\d1af9838e4bfdc89\src\TeamCity.RemoteRun\src\DelayedCommit\Impl\DelayedCommitPersistenceNewImpl.cs:line 105

when i try to access the file "C:\Users\rra\AppData\Local\JetBrains\TeamCity\v5.1\vs10.0\DelayedCommit.Settings.xml" with the rra user it is no problem and I can open it. Is it the same user that is running visual studi that is trying to access this path when tha addin is trying to read this file?

0

What is the output of 'tf.exe status' command.

0

You should check there is no devenv.exe process on your system. If you try uninstalling while devenv.exe is running some files may not be removed.

0

I've added an issue about this error into the issue tracker.
http://youtrack.jetbrains.net/issue/TW-12777

Let's continue the discussion on settings file there.

0

This was the key! RRA had some files checked out that conflicted with the project he was trying to access with the plugin. Thank you very much for your help!!!

0

No need, you suugested the solution in the ts.exe status suggestion! Tnak you for great help.


0

Issue for 'Error during collecting TFS changes. Caused by: Value cannot be null.' exception created. See http://youtrack.jetbrains.net/issue/TW-12889

0

Please sign in to leave a comment.