CVS error in teamCity rinning Build

i got an ANT Build who is cheacking out with CVS and runs perfectly if i start it from cmd Window. If i try same Build file in Teamcity, i got this Error while ANT tryes to Check out:

Caught exception: CreateProcess: cvs -d:pserver:@]]>:/mycvs/repo -z3 checkout hallo error=2

i tryed to change Teamcity settings but found nothing wich seams to be improtandt for this.

any ideas?

THX, Patrick

8 comments

Do you run agent as windows service? If so try to change user account under which agent service is running.

--
Pavel Sher

0

yes, i run agent as system service on win xp.
i tryed to start agent manualy, that it will be a users task, but if i start it with cmd, it is system service

:(

0

Not sure I understood you. Have you tried to launch agent via agent.bat script?

--
Pavel Sher

0

yes i tryed to start the agent with agent.bat, but if i start it that way agent runs as system task. too

0

Please make sure that you stopped agent service before starting agent via agent.bat

--
Pavel Sher

0

i killed process in task manager, it was not runnig, and teamcity said that there are no agents anymore, too.
after this is startet batch and, then agent was system process again...

anybody gots an idea why system process cant find my cvs.exe? java compiler errormassage is, that the cvs file was not found

0

to get more information i tryed to start cvs-command with an batchfile, it not works, too, but i got new results:

E:\cvstest>cvs checkout :
Result: -1073741515


the cvs.exe dont works right, it gives a number back... why?
or makes teamcity misstake while understanding informations from cvs?

0

Sorry for the long delay. The question is still relevant? If yes please leave a comment or create a separate thread.

Kind regards,
Marina
0

Please sign in to leave a comment.