Subversion labeling: authentication required exception

I'm setting up TeamCity as our internal build server, and so far, everything works as expected (i.e. I can get my demo-app to build), except for the labeling. I've setup the labeling rules, but after each build, I get the following exception:

Labeling failed for root 'HelloWorld' jetbrains.buildServer.vcs.VcsException:
Labeling the path 'helloworld/trunk' to 'helloworld/tags/13'
has failed with the error:
svn: Authentication required for ' Authorization Realm'
at jetbrains.buildServer.buildTriggers.vcs.svn.SvnSupport.label(SvnSupport.java:76)
at jetbrains.buildServer.vcs.impl.VcsLabeler.setLabel(VcsLabeler.java:40)
at jetbrains.buildServer.vcs.impl.VcsLabeler.access$300(VcsLabeler.java:32)
at jetbrains.buildServer.vcs.impl.VcsLabeler$3$1.run(VcsLabeler.java:2)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
at java.util.concurrent.FutureTask.run(FutureTask.java:123)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:65)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:168)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)

Caused by: org.tmatesoft.svn.core.SVNAuthenticationException:
svn: Authentication required for ' Authorization Realm'
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.authenticationFailed(SVNErrorManager.java:36)
at org.tmatesoft.svn.core.auth.BasicAuthenticationManager.getNextAuthentication(BasicAuthenticationManager.java:172)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:453)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:234)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:222)
at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.doMakeActivity(DAVConnection.java:246)
at org.tmatesoft.svn.core.internal.io.dav.DAVCommitEditor.createActivity(DAVCommitEditor.java:403)
at org.tmatesoft.svn.core.internal.io.dav.DAVCommitEditor.openRoot(DAVCommitEditor.java:85)
at org.tmatesoft.svn.core.internal.wc.SVNCommitUtil.driveCommitEditor(SVNCommitUtil.java:71)
at jetbrains.buildServer.buildTriggers.vcs.svn.SvnCopyHelper.doCopy(SvnCopyHelper.java:3)
at jetbrains.buildServer.buildTriggers.vcs.svn.SvnConnection.label(SvnConnection.java:90)
at jetbrains.buildServer.buildTriggers.vcs.svn.SvnSupport.label(SvnSupport.java:88) ... 11 more

I've entered the user/pwd in the VCS settings (and checking out the code works fine, so I assume the svn authentication works). I've also tried to create a tag manually (TortoiseSVN), and that also seems to work. Any suggestions?

thanks,

Steven

1 comment

Sorry for long the delay. The question is still actual with latest TeamCity release?

Kind regards,
Marina
0

Please sign in to leave a comment.