SVN Tunnel not working

Hi,
our repositories are accessible via a custom SVN tunnel (defined in c:\documents and settings\myname\Application Data\Subversion\config) called "ite". I can access the repository from the TeamCity machine (Server = BuildAgent) with TortoiseSVN when I enter "svn+ite://itepc73/MavSimulation/trunk/" as repository.
However, when I use the same repository location in the SVN URL field of TeamCity, I get the following exception:

java.util.concurrent.ExecutionException: jetbrains.buildServer.vcs.VcsException: Problem collecting changes for 'MyProject :: Debug' : Error collecting changes for VCS root 'MyProject SVN Root'
org.tmatesoft.svn.core.SVNException: svn: Cannot find tunnel specification for 'ite'


Is there anything I can do about that?

Thanks,
Philipp

11 comments

Hello Philipp,

  How did you setup your configuration directory in TeamCity SVN settings?
  Namely, these are parameters:

Default config directory:
Configuration directory:


  They should point to the settings which contain tunnel information.

  Regards,
  KIR

0

they do point to the svn config file containing the tunnel settings...


0

Phil,

  We've found a bug when we didn't take the tunnel specification from the configuration file. The bug is already fixed, and I'm going to send you updated version of the TeamCity svn plugin as soon as it is ready.

  Sorry for the trouble.

  KIR

0

that sounds great! Thank you!

0

Hello,

  Please put svn.zip archive from this message to $TEAMCITY_DATA_PATH$/plugins directory and restart TeamCity.
  On plugins tab in server configuration section, you should see this plugin installed (version 13539).

  Hope, this updated plugin resolves the problem.

Regards,
KIR



Attachment(s):
svn.zip
0

thanks, the tunnel is now found - but, I'm afraid, it just turned to another error message:

Error collecting changes for VCS root '(my svn root)'
org.tmatesoft.svn.core.SVNException: svn: Handshake failed, received: 'Linux <my pc name> 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux


The tunnel uses TortoisePlink.exe and SSH. As said before, TortoiseSVN works, so could there still be an issue with TeamCity?

Edit: The above error message appears during checkout, when the tunnel is only used for an svn:externals folder. If I try to create a SVN Root with the tunnel directly and click "Test Connection", it says:

Connection failed!

Invalid uploaded data, please check server log for details.

Which server log should I check?

0

Hello Phil,

   Could you please attach logs from TeamCity/logs directory? They should contain full error information.

   Thanks!
   KIR

0

Hi,
this is the VCS log:

[2010-08-27 07:17:27,230]   WARN [ion=addVcsRoot ] -      jetbrains.buildServer.VCS - Error occurred in test connection

jetbrains.buildServer.vcs.VcsException: svn: Handshake failed, received: 'Linux itepc73 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
at jetbrains.buildServer.buildTriggers.vcs.svn.SvnSupport.testConnection(SvnSupport.java:260)
(NUL)(NUL)...
    at jetbrains.buildServer.controllers.admin.projects.EditVcsRootsController.doPost(EditVcsRootsController.java:143)

    at jetbrains.buildServer.controllers.BaseFormXmlController$1.handleRequest(BaseFormXmlController.java:54)

    at jetbrains.buildServer.controllers.AjaxRequestProcessor.processRequest(AjaxRequestProcessor.java:45)

    at jetbrains.buildServer.controllers.BaseFormXmlController.doHandle(BaseFormXmlController.java:52)

    at jetbrains.buildServer.controllers.BaseController.handleRequestInternal(BaseController.java:73)

    at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)

    at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48)

    at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:875)

    at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:807)

    at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:571)

    at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:511)

    at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)

    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

    at jetbrains.buildServer.rootDispatcher.TeamCityDispatcherServlet.service(TeamCityDispatcherServlet.java:41)

    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)

    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

    at jetbrains.buildServer.web.SetThreadNameFilter.runChainWithModifiedThreadName(SetThreadNameFilter.java:5)

    at jetbrains.buildServer.web.SetThreadNameFilter.doFilter(SetThreadNameFilter.java:7)

    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)

    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

    at jetbrains.buildServer.web.ResponseFragmentFilter.doFilter(ResponseFragmentFilter.java:2)

    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)

    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)

    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)

    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)

    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)

    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)

    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:852)

    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)

    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)

    at java.lang.Thread.run(Thread.java:619)
0

Hello Phil,

  Could you please disable sshd banner in the sshd settings on the SVN server?

  This can be done with 'Banner none' directive in sshd_config on the SVN machine.

  Hope, this helps,
  KIR

0

thanks for the hint!
It wasn't really the banner, but when our administrator changed the bash.bashrc script to not output the lines that can be found in the log, it is now finally working. I don't really understand why these lines are a problem for Teamcity but not for TortoiseSVN, but we can live with the changed bashrc script.
Philipp

0

Phil,

   Really good news, glad it works for you :)

   Best regards,
   KIR

0

Please sign in to leave a comment.