Teamcity web page not accessible after new install

Hi,

I'm a new comer to TeamCity and been having a little trouble. Just been trying to get it going on a new Linux box which is running Debian 5.06. I have:

- Installed the default-fre and default-jdk packages

- Extracted TeamCity to /home/build/TeamCity

- Executed runall.sh and I get the following output:

Using CATALINA_BASE:   /home/build/TeamCity
Using CATALINA_HOME:   /home/build/TeamCity
Using CATALINA_TMPDIR: /home/build/TeamCity/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /home/build/TeamCity/bin/bootstrap.jar
Starting TeamCity build agent...
Done [7855], see log at ../logs/teamcity-agent.log


Which seems fine. But when I go to localhost:8111 I get a request timed out.
Checked server.xml and the port is indeed set for 8111.

All logs are empty except for catalina which contains:

SEVERE: Class loader creation threw exception
java.lang.InternalError: One of the management beans is not compliant.
   at java.lang.management.ManagementFactory.getPlatformMBeanServer(libgcj.so.90)
   at org.apache.catalina.startup.Bootstrap.createClassLoader(Bootstrap.java:183)
   at org.apache.catalina.startup.Bootstrap.initClassLoaders(Bootstrap.java:92)
   at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:207)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:391)
Caused by: javax.management.NotCompliantMBeanException: MBean is not compliant
   at mx4j.server.MX4JMBeanServer.registerImpl(MX4JMBeanServer.java:818)
   at mx4j.server.MX4JMBeanServer.registerMBeanImpl(MX4JMBeanServer.java:769)
   at mx4j.server.MX4JMBeanServer.registerMBean(MX4JMBeanServer.java:753)
   at java.lang.management.ManagementFactory.getPlatformMBeanServer(libgcj.so.90)
   ...4 more


Haven't really be able to find any documentation or people with a similar problem while installing TeamCity.

I've tried executing the runall.sh script as root, having only default-jre and default-jdk installed but no go.

Any help is really appreciated.

Cheers

1 comment

Just solved it! For those who have a similar problem:

The debian default-jre was an old/wrong version it serms. Uninstalled it and default-jdk after finding "java6-runtime". Installed that and it all works great now.

0

Please sign in to leave a comment.