First time with teamCity : I need some help, please

Hello,

I am really a beginner with this king of solution... it is my first experience with the continuous integration.
I develop with cpp since four years, but always with more or less little projects.
So the first step was to install : visualSVN, tortoiseSVN and finally TeamCity.
And the second one was to realize my first build task, and then it was again and again a failure... since two entire days...

Obviously, I got and read a tutorial, and I read the internet documentation pages....
If someone could help me, because I am completely lost, it will be very cool....

So I began with the installation of : 1. visualSVN,  2. tortoiseSVN

I have a Repositorie : /TestTeamCity
with under folders : trunk, tags and branches

I did a checkout on the folder : c:/.../TestTeamCity/  

And I put a simple cpp project in the trunk folder, and after that I did a commit...
Without problems for the moment.

After that, I installed teamCity without problem...
The localWebSite was launched :  http://localhost

I registred my admin account without problem, and I created my first project like the following :

1. Getting Settings : Nothing to say

2. Version Control Settings

I created a new VCS root : Subversion, ... the Test Connection was OK.

3. Build Runner

     a. Build runner : Visual studio
     b. Solution file path : \trunk\teamCityCPP\teamCityCPP.sln
     c. Working directory : blank
     d. Visual Studio : Microsoft Visual Studio 2005
     e. Targets : Rebuild
     f. Configuration : Release
     g. Platform : blank
     h. Command line parameters : blank
.... and the default parameters for the others....

4. Build trigger : if a modification on the svn server...

This task is really simple, I suppose, but it is really for begin... I am not really an extrem developer...

So I started the build like that and there is always this error message when I run the build :

Compilation failed

C:\TeamCity\buildAgent\work\30f0fa45b67da4d3\trunk\teamCityCPP\teamCityCPP.sln error MSB4126:
The specified solution configuration "Release|MCD" is invalid. Please specify a valid solution configuration using the Configuration and Platform properties (e.g. MSBuild.exe Solution.sln /p:Configuration=Debug /p:Platform="Any CPU") or leave those properties blank to use the default solution configuration.

I begin to become crazy, so I will be very happy if someone could help me...
If it's only a simple error of configuration, or if I am completely out of bounds....

Then, many thanks....

Peupeu

18 comments

Hello,

maybe you need more information to fix my problem, so I forward many screenshots...
I put the VCS page, the runner page with the teamCity folder explorer with the cpp project...

So my goal is really simple, it's only to realize a automatic build action on my cpp project... and with this build configuration, I have always the same error result

Compilation failed

C:\TeamCity\buildAgent\work\30f0fa45b67da4d3\trunk\teamCityCPP\teamCityCPP.sln error MSB4126:
The specified solution configuration "Release|MCD" is invalid. Please specify a valid solution configuration using the Configuration and Platform properties (e.g. MSBuild.exe Solution.sln /p:Configuration=Debug /p:Platform="Any CPU") or leave those properties blank to use the default solution configuration.


I tried other seetings, but they always failed too.
So if someone could help me, it will be very helpfull for me.
Many thanks  in advance...



Peupeu



Attachment(s):
teamCityFolderExplorer.jpg
runnerPage2.jpg
runnerPage1.jpg
vcsPage2.jpg
vcsPage1.jpg
0

Hello Pierre,

Can you please try to run solution using MSBuild.exe from command line under the same user account at the agent machine?

Regards,
Marina

0

Hello,

thank you for your answer.

I tried also with MSBuild, with the following Build Runner Configuration, but the build result is still the same....

best regards,

Pierre



Attachment(s):
Error log.jpg
Build runner Page.jpg
0

Pierre,

I meant to run it without TeamCity. Try run the build with MSBuild.exe from commandline on the build agent from the same directory under the same user account as used to run build agent but without TeamCity.

Thanks in advance,
Marina

0

Marina,

I run a MSBuild since the build agent, but the result is exactly the same....
You can see the command prompt attached...

I have to say this exemple cpp solution is quite simple and from Visual Studio application, the solution build correctly...
I am lost...

Thanks

Pierre



Attachment(s):
Manual MSBuild.jpg
0

Pierre, I noticed you have selected x64 msbuild. Do you really need this? This could be an issue for c++ builds.

As the msbuild .exe has failed from commandline, please try checking your solution files to make them compatible with msbuild.exe. TeamCity does nothing, but starting msbuild.exe for you. You could probably try checking possible issues from here: http://confluence.jetbrains.net/display/TCD5/Visual+C+Build+Issues

Please open configuration manager in VS and make sure you have all configurations defined in all projects.

0

Hello Eugene,

I begin to become crazy, because I've another PC which is running with Windows XP, and when I run a MSBuild on a very simple project, with a commandline...
The build is ok...

But with my principal PC, which is running on Vista x64... there are problems...

So the problem is with the target : ValidateSolutionConfiguration
error MSB4126 : the specified solution configuration "Debug|MCD" is invalid.

But I have to say I have no idea how to fix it...

0

Eugene,

I deal with the configuration manager... I test all the config... but I have always the same error message...
I don't understand because, the solution build well from visual studio, and if I am right, visual studio uses msbuild when I do a build action....

Maybe, it's another way... I have a Vista 64bits... Maybe I need a patch... a SP plugin....

I think it's obviously a config problem, because with XP, MSBuild works good....

I dont know....

0

As workaround you may use commandline build runner and run deven.exe there to build your solution from commandline mode.  To tell the truth, there is VCBuild that is called from MSBuild to build your solution. Visual Studio uses tuned version of MSBuild to run the build. Please check you run the build under administrative account.

Make sure you have checked in all sources from your personal PC. Will the build be working if you setup build agent on that PC? Will the build be working if you checkout in to another folder and run with msbuild.exe <path-to-solution>.sln?

0

I succed finaly to build my project with MSBuild, but always not with TeamCity...
But now, the message error is not the same :

c:\teamcity\buildagent\...\trunk\TCproject\TCproject.cpp error C1902: Program database manager; please check your installation

0

Please see this:
http://msdn.microsoft.com/en-us/library/8y7hea02.aspx

You may need to check PATH variables on the build agent.

0

Hello Eugene,

I checked in IDE folder, and the mspdbsrv.exe and mspdb80.dll are there.

And about your message, how can I check PATH variables on the build agent?

Regards

0

I have attached the Build Parameters, is it normal?

And is it linked with your last message?



Attachment(s):
build config.jpg
0

Ok, I understand than during the compilation, Visual needs mspdbsrv.exe and mspdb80.dl, which are localized in the follwoing folder :

c:\Program Files\Microsoft Visual Studio 8\Common7\IDE

So I put this path in the PATH variable (in the control panel) and also in the build configuration page, like on screenshot attached...

But the compilation is still not OK...

I am completly discouraged by that...



Attachment(s):
Path Env.jpg
Path Build Page.jpg
0

I would recommend you to add VS to PATH variable in the system settings.
To check actual path variables, consider running a build with commandline runner with process "cmd.exe" and arguments "/c set"

0

I did the build as you specified, and the build was successed.

The cmd result is attached, and you can see at the PATH line, there is the VS path :

C:\program Files(x86)\Microsoft Visual Studio 8\Common 7\IDE

This is the  good path for :
- devenv.exe  (the visual studio exe)
- mspdb80.dll
- mspdbsrv

It should be ok....

However, I attached also a build action with MSBuild, firstly from cmd (which is successed), and secondly with TC, I put the build config and the build result...

I understand nothing... I have to put in place this environment, and currently I am really lost....



Attachment(s):
Build result with MSBuild rebuild.jpg
Build Config with MSBuild rebuild.jpg
CMD build from MSBuild.jpg
cmd c set.jpg
0

It's amazing, because now, I just tried to run clean action from TeamCity with runners commandline, MSBuild and VisualStudio...

And they worked....

But about another action, like Build or Rebuild, I've got always the same error : C1902...
So it's really a VS error... but I always don't know wwath I have to do to fix this problem about mspdb files....

Maybe, I'll try to take my PC and throw him through my window, hehe...

0

Finaly I found the solution of my problem!!!!!!!!
I can breath now, hehe !!!!!!!

So the solution is very simple, download and install the MS hotfix at the following adress :

http://code.msdn.microsoft.com/KB920770/Release/ProjectReleases.aspx?ReleaseId=752

Well, many thanks about the time you took to answer me!!!!

Good weekend!!!

Pierre

0

Please sign in to leave a comment.