Access Server Via HTTP Problem

By referring to http://confluence.jetbrains.net/display/TCD5/Accessing+Server+by+HTTP, I tried to set up a way to invoke a build via HTTP request.

(Currently, I am using TeamCity Professional 5.1.1 (build 13398) )

Everything is fine, except one, when I tried to invoke a historical build.

I have tried a few ways already, but none of them behave in expected way (all of them run the newest build instead of historical build):

  • "http://<myuser>:<mypassword>@<myserver>/httpAuth/action.html?add2Queue=bt9&agentId=2&modificationId=747b82e185b1" where ModificationID is the "Revision" number that I found in the "Change" tab of my build configuration.
  • "http://<myuser>:<mypassword>@<myserver>/httpAuth/action.html?add2Queue=bt9&agentId=2&buildNumber=0.0.3.20" where buildNumber is one of the historical "#" of my build configuration.
  • "http://<myuser>:<mypassword>@<myserver>/httpAuth/action.html?add2Queue=bt9&agentId=2&buildId=100"
  • I have also tried to pin a historical build then invoke "http://<myuser>:<mypassword>@<myserver>/httpAuth/action.html?add2Queue=bt9&agentId=2&buildId=lastPinned", but it also just run the newest build.



Any help is appreciated.  Thank you very much.

2 comments

Sorry for delay.

Unfortunately you can't use revision as modification id. This id is TeamCity internal identifier assigned to each change list discovered by the server. You can see it in the browser address bar if you try to view diff on a file in some commit (modId parameter).

0

Thanks a lot for your help. That actually solve large part of problem now. Is there any existing mechanism to export these modification IDs to some external tools to show them as a list of change made by teamcity?

0

Please sign in to leave a comment.