SourceSafe and the command to get the source

Hi all,

I am using Teamcity Professionnal 5.1.2 and I tried several times to use sourcesafe with no success : it fails using this command :

"C:\Programmi\Microsoft Visual SourceSafe\ss.exe" Get $/super/ -R -Vd01/10/2010;95515 -Y*****,***** -I-Y -W -GF- -GTM -GWR


I have tried this command line and it did not work. But when I modified it a bit to get for instance this :

"C:\Programmi\Microsoft Visual SourceSafe\ss.exe" Get $/super/ -R -Vd01/10/2010;09:56:00 -Y*****,***** -I-Y -W -GF- -GTM -GWR

It worked like a charm.

My question is : How can I can modify Teamcity so that it doesn't take its source like it does but like my second option ?

Thx for your support,

Arthis
3 comments

Please file an issue to out issue tracker at http://youtrack.jetbrains.net
What is the locale settings of a user account the run TeamCity build agent?

In general, time format depends on system settings. We call native process to fetch those settings.

0

I have the time defined in the Italian format :

hh.mm.ss

9.16.38

Date is more common :  dd/mm/yyyy 04/10/2010

Thanks for your help Eugene, I am not sure I will dig this matter depper, as I am trying to push my team to switch to SVN. But if I do I will submit an issue in your issue tracker with some more information.

Thanks for your help,

arthis

0

Please try changing locale to EN-US for TeamCity server running user account. That should help!
Do not forget to reboot/log off and log on after changing it to make change apply.

0

Please sign in to leave a comment.