Artifact wildcards

Hi,

I am using wildcards to grab the artifacts from a build but teamcity includes all the directories the wildcards match.  Is there a way around this?  For example:

Dir1/Dir2/Dir3/*.rpm

I am using:

**/Dir3/*.rpm

If I look at the artifacts tab after a build it includes Dir1 and Dir2.  I would like to have it only include the *.rpm files and not the directory structure or at the least put it into an rpms directory using the "=>" option.

The Dir3 changes frequently which is why I need to use wildcards.

Thanks,
Jay

2 comments

Jason,

Unfortunately, there is no such way for now to exclude directories. The artifact pattern are processed in such a way that any pattern-matching path part is included into the target paths.

The workaround is to use full path Dir1/Dir2/Dir3/*.rpm in this case directories matched by "static" text will not be created.

Anyway, feel free to file a feature request into our tracker at http://youtrack.jetbrains.net/issues/TW

Kind regards,

Marina

0

Please sign in to leave a comment.