Tigris teamcity msbuild runner

Hello,

I created a msbuild runner which is executing the following script :


<?xml version="1.0" encoding="utf-8" ?>
<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003" DefaultTargets="EnvironmentInfo">

  <Import Project="$(MSBuildExtensionsPath)\MSBuildCommunityTasks\MSBuild.Community.Tasks.Targets"/>

  <Target Name="EnvironmentInfo">    
    <Message Text="MSBuildExtensionsPath $(MSBuildExtensionsPath)" />
    <Message Text="MSBuild.Community.Tasks.Targets is missing." Condition="!Exists('$(MSBuildExtensionsPath)\MSBuildCommunityTasks\MSBuild.Community.Tasks.Targets')" />
    <Message Text="MSBuild.Community.Tasks.Targets exists." Condition="Exists('$(MSBuildExtensionsPath)\MSBuildCommunityTasks\MSBuild.Community.Tasks.Targets')" />
    <User>
              <Output TaskParameter="UserNameWithDomain" PropertyName="BuildUserID" />
              <Output TaskParameter="FullName" PropertyName="BuildUserName" />
              <Output TaskParameter="Email" PropertyName="BuildUserEmail" />
              <Output TaskParameter="Phone" PropertyName="BuildUserPhone" />
         </User>   
    <Message Text="User $(BuildUserID)" />
  </Target>

</Project>


Locally using commandline msbuild it works great!

When I run this script from Team City  I get the following error :

build.xml(33, 2): error MSB4036: The "User" task was not found.

What am I doing wrong?

Can someone help me out?

Greetings René

5 comments

Tigris is installed on the agent which is executing the msbuild file.

0

I tried to use the using task like :  

<UsingTask TaskName="User" AssemblyFile="$(MSBuildExtensionsPath)\MSBuildCommunityTasks\MSBuild.Community.Tasks.dll" />
<UsingTask TaskName="Robocopy" AssemblyFile="$(MSBuildExtensionsPath)\MSBuildCommunityTasks\MSBuild.Community.Tasks.dll" />

Still the agent can't find the task.

Can somebody help me?

0

Instead of the nightly build, the release version of msbuildtasks.tigris.org was installed on the agent. :)

0

Does the issue reproduces still?

Check user account that is used to run build agent windows service.

0

Please sign in to leave a comment.