TeamCity EAP: 15509 - Code coverage questions

Hi,

So far I'm really enjoying the new features that TC6 offers.  I'm running into a bit of a snag when it comes to code coverage, though.  Right now, my project has two build steps:

  1. Visual Studio (sln)
  2. MSTest


Both appear to be working fine, but I'm not really sure where to put the information related to run code coverage.  It was placed at the bottom of the Visual Studio build step, as part of the TC upgrade process.  Wouldn't that be too soon, since the unit tests wont have run by then?  I tried to add another build step (MSBuild) to the project, but the code coverage area is all sorts of messed up.  The drop down isn't populated and all of the code coverage options, for every tool, are shown.  

Is there a recommended practice for how to get code coverage working with TC6?

2 comments

As a test, I changed the code coverage tool, on my Visual Studio build step, to DotCover.  Again, it doesn't appear that the code coverage tool is being run.  I'm indifferent at this point if I use PartCover or DotCover, but I would like to use one of them :)  

0

Please vote for http://youtrack.jetbrains.net/issue/TW-14144

Actually, there are only a few cases when it's necessary to have '.NET Coverage' enabled to SLN runner. I plan to remove .NET Coverage section from solution SLN runner settings.

In general, enabling .NET Coverage for ordinary SLN build will do nothing, because inside SLN build where will be no tests started.

0

Please sign in to leave a comment.