Configuration Mismatch: Old configuration Newer Database

Hello,

I am attempting to upgrade my Teamcity from 4.5 to 5.1. I am not doing an inplace upgrade since I am actually moving to a different server.

So here are the steps I took...

I am using Centos 5.5

I installed Java JDK & JRE

Installed Apache Ant & Tomcat

Downloaded the 5.1 WAR file and extracted it into a teamcity directory in webapps.

Downloaded the MYSQL jdbc connector.

Launched it via tomcat manager and it came up and allowed me to create an account.

I then backed up my 4.5 .BuildServer folder and did a database dump of the teamcity database.

On my new 5.1 server I imported the 4.5 database and moved my 4.5 .BuildServer directory over the 5.1 installation directory. I saved a copy of the 5.1 .BuildServer directory just in case.

I don't know anything about TeamCity to be 100% honst with you... I'm the network/system administrator and network security for my company. I'm the only one here and I never work with it. All the software engineers do everything with it. So I hope I wasn't too ignorant with the way I performed this.

So I restarted tomcat and reloaded teamcity. Now I get the following message:

Database version mismatch: Configuration version is 280 but Database version is 379.

So it appears that the Database was upgraded by my configs weren't....

I tried copying the 4.5 .BuildServer/config folder out and moving the 5.1 config file in but still same message.

I'm sure I just did something really stupid and am hoping someone can point it out to me. Thanks a lot

3 comments

          I still have the original server running as well as a copy of the data folder I copied from the 4.5 and the dumped database before I through them intot he 5.1 installation.

Does anyone know what I did wrong during the installation and if it might just be easier to start the installation over?

0

Keith,

The steps you took should've worked, but the error message suggests that the step of importing the 4.5 database to the new 5.1 database didn't work. If you try this again I would drop all tables from the database before importing the 4.5 backup.

When I've tried newer versions of TeamCity I usually clone the existing environment, get it working then upgrade by dropping in the new war file, this upgrades the configuration files and the database together.

Rod

0

I used to work with a guy named Rod Mackenzie when I was in the Marine Corps... Same spelling and everything.

Anyways, Thank you so much for your response.


I actually got the data from a clone I had captured. Wanted to do everything the safest way possible without possibly destroying the in place TeamCity. My CEO and the engineers would probably be pretty miffed.

So I'll try it that way... However, I still want to change Operating Systems. So do you think the best way would be to upgrade the clone like you talked about. Then when the clone is upgraded...THEN copy the data and the database out to a new installation on a new OS that way I don't have to worry about the upgrade? It's just replacing data that way?

Thanks.

0

Please sign in to leave a comment.