Permission Denied Error While Accessing ClearCase Dynamic View From TeamCity

Hi,
I am getting Permission Denied Error While Accessing ClearCase Dynamic View From TeamCity.
Here is my Configuration for the Project
Please find the Files attached for each Step in the attached Doc.
I have only one issue in this Confuguration that whenever i ran this build it gives me Access Denied Error fo my Dynamic View.
If i use Xcopy from Commandprompt then it copies the files perfectly ,but wheever i try to run the Xcopy from Nant Script it give me Access Denied Error.
Also i tried to Test Connection from Step 2 (Version Control Settings) and i am able to connect Successfuly(find the attached txt fileTestConnection.txt).
I am able to Copy / Read the files from my Mapped M:\


Regards,
Hemant



Attachment(s):
TestConnection.txt.zip
onlyBuild.build.txt.zip
TestConnection.txt.zip
ConfigDoc.doc
2 comments

Hi TeamCity Team,
Can you help me ?

0

Hello,

Looks like an issue with permissions of the user that TeamCity agent runs under. Can you please isolate this, e.g. like:

- stop the currently running agent that has the issue

- run the agent from console window under a user that has write access to the directory in question. (use "bin/agent.bat" to start/stop the agent).

Does this help? Then the issue is in the way the agent is run.

If you need further help please describe how you run the agent, etc.

Please also check the list of conflicting software: http://confluence.jetbrains.net/display/TCD6/Known+Issues#KnownIssues-ConflictingSoftware.


Hope this help,

Marina

0

Please sign in to leave a comment.