Problem with artifacts in Teamcity

In our build projects we ask TeamCity to publish some artifacts to a location above the build folder. We've been doing by identify the relevant artifact then using "=>" notation to indicate the desired folder i.e.

Mocks/bin/release/HST.Core.Mocks.dll => ../

To put it a folder above.

This has been working fine for a few iterations of TeamCity - right up to TeamCity 5.13, but when we upgraded to TeamCity 5.14 it stopped working. It still doesn't work in TeamCity 6.0

I've had a look through the documentation and can't see anything about the feature being changed or replaced.

Has the feature been dropped or replaced ? Or is there a problem ?

Thanks in advance.

Simon

1 comment

Simon,

Do I understand you right that you have "Artifact paths:" setting set to the line mentioned?

This is not a supported case. It worked in previous verisons due to a bug that was fixed in 6.0.

Can you please explain what is your expected behavior when you specify "../" in the target of artifacts? Why do you need this for?

0

Please sign in to leave a comment.