Agent problem after migration 5.1.5 -> 6.0.1

Hi,

I just upgraded TeamtCity, and I'm having problem finding a compatible agent.

In y default agent Compatible Configuration tag, all my projects are displayed with the following problems:

Incompatible runner: Maven2
Missing VCS plugins on agent:
  • Subversion


Referring to Missing VCS Plugin on agent thread (http://devnet.jetbrains.net/message/5279437), I've tried to stop the agent, delete the plugins directory, restart, to n avail.
I've then reinstalled an agent from scratch, by downloading it from TeamCity itself, and got the exact same result.

please help!!

8 comments
Comment actions Permalink

Could you please attach all of the agent logs?


0
Comment actions Permalink

Hi Pavel,

I've attached the logs from the 2 agents:

  • the original one, that got updated by TeamCity-6.0.1
  • the new one I downloaded directly from TeamCity afterwards


HTH



Attachment(s):
newAgent.zip
migratedAgent5.1.5-6.0.1.zip
0
Comment actions Permalink

Hi,

it'd be good to have an answer on this problem.
If it's not possible to get a working agent, I'll have to revert to the previous version - I'd rather avoir that :(

Migration was motivated by the following problem TW-14967 , happening on 5.1.5

cheers

0
Comment actions Permalink

Hello,

  Sorry for the problem.
  Could you please send list of files (ls -lR) under TeamCity server folders:
  TeamCity/webapps/ROOT/update/plugins/
  and
  TeamCity/webapps/ROOT/WEB-INF/plugins/svn/

  I suppose that you may have a broken TeamCity 6.0.1 installation :(

  Best regards,
  KIR

0
Comment actions Permalink

My TeamCity install is a WAR in Tomcat, ao the path are a little different.
I dont' suppose it's a problem, here's what I did:

ls -lR tomcat/webapps/TeamCity/update/plugins/ > ROOTupdatePluginsList.txt
ls -lR tomcat/webapps/TeamCity/WEB-INF/plugins/svn/ > ROOTwebinfSVNpluginList.txt



The resulting files come as attachement.

cheers

Attachment(s):
ROOTupdatePluginsList.txt.zip
ROOTwebinfSVNpluginList.txt.zip
0
Comment actions Permalink

Hello,

  Looks like TeamCity server was unable to unpack some agent-side plugins during server startup.
  Please try restarting TeamCity server - after initialization, tomcat/webapps/TeamCity/update/plugins directory should contain much more zip files.

  Please also make sure that you're running TeamCity under the same account as before. Given that all files in tomcat/webapps/TeamCity/update/plugins
  are owned by root, you probably should run your web container under root as well.
  Or, make sure that tomcat/webapps/TeamCity/update/plugins directory is writable by an account you're running TeamCity server under.

  If all of the above won't help, please attach your TeamCity server logs.

  Hope, this helps,
  KIR

0
Comment actions Permalink

hello Kirill,

thanks a lot, it works now. Can't know for sure what was the problem for sure, but probably permissions indeed.

Good catch, I generally unpack the WAR manually in order to be able to copy the MySQL JDBC driver by hand. I forgot to change permissions. Sorry about that.

It won't happen again, as a nice and clear TeamCity error message told me I have the possibility to put that driver in /var/opt/local/teamcity/lib/jdbc, that is my data folder. So much better!

cheers

0

Please sign in to leave a comment.