Display completed Gallio tests on View Tests?

The log shows that TeamCity ran Gallio/MbUnit tests but the tests don't display under the View Tests page. Is there something that has to be configured?

14 comments

Hello,

Starting from 3.0.4 Gallio/MBUnit supports TeamCity native way to report tests results. What version do you use? Could you please also provide the build log?

Kind regards,
Marina

0

Gallio 3.1.0. Can I email the build log to you?

0

You can use teamcity-feedback@jetbrains.com to send the logs (please refer to this thread).

Did you look through the Gallio blog post referenced in the doc?

0

Please check all environment variables from build process are set as environment variables for Gallio test runner. It use those variables to check the build is running under TeamCity build agent.

0

Are you referring to the Gallio assemblies?

0

Yes. Gallio checks for environment variable to enable/disable TeamCity extension

0

So I need an env var for the Gallio\TeamCity directory. Does it matter what's it called, do I need to do anything else?

0

How do you start Gallio? Do you have any explicit settings for environment variables?

0

I'm just referencing the assemblies location from the Nant build file.

0

Please describe the way you run Gallio in details.

0

I'm using nant build files and I run those via TeamCity build.

I call the nant task, which has the following:

<target name="test">
<gallio result-property="exitCode" failonerror="false" >
            <assemblies>
                <include name="${testdir}\${testname}"/>
           </assemblies>
</gallio>
<fail if="${exitCode != '0'}" >Test failed</fail>
</target>

As I said, the log shows that these tests are run by TeamCity but TC doesn't report the results.

0

I've read these before but it doesn't help. I'm using Gallio 3.0.5xxx and I'm pointing the build at the directory housing the entire Gallio install with all of the plugins and assemblies. I tried using the runner-extension but I got an error stating unexpected attribute.

0

I failed to download bits of the 3.0.5 version, this build seems to be quite old. Could you please try running under latest Gallio as experiment.

0

Please sign in to leave a comment.