Builds broken with upgrade to TeamCity 6.0.1

I upgraded my Teamcity instance to 6.0.1 from 6.0 EAP(build 15311) Multiple Build Runners, all my builds were working fine on the earlier version.
The installation went smooth, newer version uninstalled the log files(kept the config files), after install I entered the maintenance token, the scripts were upgraded to latest version,
however when I queue a new build now I get the error

Incompatible runner: Visual Studio (sln)
Unmet requirements:
  • DotNetFramework3.5_x86 exists

Missing VCS plugins on agent:
  • Team Foundation Server


I have tried using checkout on agent and checkout on server and get the same error on both.


Any pointers?
Thanks

1 comment
Comment actions Permalink

Hi

Seems agent upgrade went wrong, and now it misses some plugins. I suggest you

  1. Stop agent service,
  2. clear <agent home>\plugins folder,
  3. restart the service.

It will reinstall all plugins once again.

If that doesn't help, please attach your teamcity-agent.log and upgrade.log.

Michael

0

Please sign in to leave a comment.