How to integrate dotcover in teamcity?

Hello,

I have the RC2 version and changed the settings of code coverage to be with dotcover, but I can't see any result.

What is wrong? any ideas..?

By the way my last post has been deleted somehow...

Thanks in advance.

17 comments
Comment actions Permalink

Does build log have any related lines?

Can you post it here?


> By the way my last post has been deleted somehow...

Should not happen regularly. That can be a forum engine misbehavior.

0
Comment actions Permalink

Related to what? (No, I can't post sorry :()

0
Comment actions Permalink

> Related to what?

Related to dotCover.

If you just do not want to to make the log public, you can send it to teamcity-feedback@jetbrains.com noting this thread in the message.

0
Comment actions Permalink

If you mean to the logs that are located in the directory "c:\teamcity... \logs" (something like that), so there is no any file that is related to dotcover...

0
Comment actions Permalink

Can you attach the build log here (the one available from "Build Log" tab for the build in the web UI)?
It also probabaly makes sence to install TeamCity 6.0 final.

0
Comment actions Permalink

I can't see this "bulid log" tab. The only log tabs I have are : "Change log" and "Issue log".

0
Comment actions Permalink

You are probably referring to a build configuration page. Try clicking on the specific build that you have issues with.

0
Comment actions Permalink

Ok I found the build log tab and there are no lines related to dotcover..

0
Comment actions Permalink

Cool.

Please attach the build log and the screenshot of the build configuration dotCover settings so that we can investigate this.

Also, I'd recommend to use TeamCity 6.0 release build.

0
Comment actions Permalink

Sorry for the delay...

The build log shows me an error and says "Value cannot be null". and If I abort the settings of dotcover the tests continue regularly.

I'm not allowed to attach the build log. I'll be glad if you can help me somehow and if not it seems that I'll give up .

By the way I have the RC2 version because in my previous post I was told that it's necessary for working with dotcover.

0
Comment actions Permalink

I did not find where you were told to prefer RC2 over the final 6.0 release. In any case this would be quite strange recommendation. So as Yegor told I would recommend to upgrade to 6.0.1 (we already have 6.0.1 version released) and try again.

0
Comment actions Permalink

Sorry for the mistake.. I meant RC1 version that someone recommended to me in my previous topic (it was deleted somehow).

Is 6.0.1 the newest version?

Can you give me please all the relevant guides for integrating dotcover and getting the code coverage tab (in the web UI)?

0
Comment actions Permalink

Yes, 6.0.1 is the newest version at the moment. Please refer to our documentation for information about dotCover integration with TeamCity: http://confluence.jetbrains.net/display/TCD6/JetBrains+dotCover

0
Comment actions Permalink

Thanks I'll try..

I wondered if I need to purchase teamcity as well as dotcover or the trial is enough for starting?

0
Comment actions Permalink

TeamCity includes dotCover engine, so you don't need to buy or install dotCover separately.

Michael

0
Comment actions Permalink

And if I download teamcity, is it enough?

Thanks a lot.

0
Comment actions Permalink

Yes, it's enough.
But to clarify -  TeamCity server includes dotCover engine (no separate install is required). You can just enable it in build configurations, and see coverage statistics and detailed reports in web interface. All of that is for free, if you use TeamCity Professional Edition.

If you like to have coverage functionality integrated to Visual Studio, then you'll need to buy and install standalone dotCover product.

Michael

0

Please sign in to leave a comment.