Build Agent Source Control Skipping Files

difficult to explain this as i dont know the correct terminology for everything but here goes...

Setup:

im using 5.1.2 on a vmware virtual machine, with one locally installed agent. i am using an msbuild script to perform a variety of tasks during the build process, including updating version numbers, ftp'ing to our website, updating database records, copying to local network drives etc...

Problem:

There are numerous non vs2010 files required by this script (they ARE in our source control) however they are not in the directory i set as the check out folder, thus the build fails with missing files!

i.e.

C:\Dev\CheckOutDirectory

     \source files in this folder

     \but not all of them!!!!

C:\Dev\ExactRepoName

     \.hg

     no source files here in this folder

(this one is shown as a source controlled directory, but its not the folder i selected as the check out directory)

I can understand there being two folders, one being the source controlled folder of the tc server and one for each of the agents (which happens to be one, on the tc server in this case) however what i dont understand is why the agent doesnt get ALL the files in the source tree??

Please help,

I can fix this by copying these files across from the source controlled folder to the build agents folder for now, but should i make changes or add extra files at a later date the build will start to fail again until i manually copy these files into the agent folder...

what i want to know is why the agent is missing only some files, its not the solution files but additional files required by the mbbuild script that are being skipped???

1 comment
Comment actions Permalink

Hi Matt

Of course, copying the files manually is not a solution. All the sources should be put to version control and be built automatically.

Actually TeamCity web server does not store a copy of sources, only agent has it.
Checkout directory is an optional settings and we do not recommend to set it, until your build scripts rely on absolute paths.

I would suggest to

  • recheck VCS root settings to ensure TeamCity looks to correct branch within your repository
  • look at checkout rules, they may contain exclusions
  • ensure TeamCity agent is the only process that modifies files within checkout directory
  • perform clean checkout


Also, you mentioned ExactRepoName folder - how does it relate to TeamCity configuration?

Thanks
Michael

0

Please sign in to leave a comment.