Error integrating with Kiln (Mercurial and named branches)

I am trying to use TeamCity to build one of our Kiln-hosted mercurial repositories. Unfortunately, it doesn't appear to be working.
Here's what I tried:

Pull changes from: https://companyname.kilnhg.com/Repo/Repositories/RepoGroup/MercurialRepo
Branch name: OurBranchName


The "Test Connection" works fine, but then when I go to the project page, I got this error:

Unable to find current version for the branch: OurBranchName

Stack trace:
jetbrains.buildServer.vcs.VcsException: Unable to find current version for the branch: YNABAIR/Flex3.5
at jetbrains.buildServer.buildTriggers.vcs.mercurial.MercurialVcsSupport.getCurrentVersion(MercurialVcsSupport.java:207)
at jetbrains.buildServer.buildTriggers.vcs.VcsChangesLoader.getCurrentVersion(VcsChangesLoader.java:43)
at jetbrains.buildServer.vcs.impl.VcsManagerImpl.getVersionsForAllRoots(VcsManagerImpl.java:213)
at jetbrains.buildServer.vcs.impl.VcsManagerImpl.loadChanges(VcsManagerImpl.java:332)
at jetbrains.buildServer.serverSide.impl.auth.SecuredVcsManager.loadChanges(SecuredVcsManager.java:49)
at jetbrains.buildServer.serverSide.impl.VcsModificationChecker$1.run(VcsModificationChecker.java:13)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

So, based on the advice of this thread, I changed the branch name to be "MercurialRepo"

Well, that worked, but now there is no place for me to specify which of the branches I want TeamCity to build. Without this ability, we're dead in the water since we don't want to build from our default branch. We can't build the code we'd like to...Any advice or comments would be greatly appreciated!

1 comment
Comment actions Permalink

My sincere apologies. Looks like I jumped the gun. I misnamed my branch name in my configuration, so sure enough, TeamCity was right: It couldn't get the version of the branch I gave it! When my Google search turned up someone with the exact same problem, I missed the obvious solution, which was making sure my configuration was right!

0

Please sign in to leave a comment.