Teamcity+Ubuntu+Mono2.10+msbuild == Unmet requirements

I've tried search for an asnwer to this but I've not made any progress.

I've installed teamcity 6.0.2 on an Ubuntu 10.10 server with mono 2.10.
I've set up some environment variables in the start up script:

#!/bin/sh

#

# /etc/init.d/teamcity -  startup script for teamcity

export JAVA_HOME=/usr/lib/jvm/default-java

export PATH=/opt/mono-2.10/bin:$PATH:$JAVA_HOME/bin

export PKG_CONFIG_PATH=/opt/mono-2.10/lib/pkgconfig

case $1 in

start)

/opt/teamcity/bin/runAll.sh start

;;

stop)

/opt/teamcity/bin/runAll.sh stop

;;

restart)

/opt/teamcity/bin/runAll.sh stop

/opt/teamcity/bin/runAll.sh start

;;

esac

exit 0

but from what i can tell the build agent can only see x64 mono runtimes as the detected system variables are:
Mono /opt/mono-2.10/lib/pkgconfig/../../bin/mono
Mono2.0 /opt/mono-2.10/lib/mono/2.0
Mono2.0_x64 /opt/mono-2.10/lib/mono/2.0
Mono3.5 /opt/mono-2.10/lib/mono/3.5
Mono3.5_x64 /opt/mono-2.10/lib/mono/3.5
Mono4.0 /opt/mono-2.10/lib/mono/4.0
Mono4.0_x64 /opt/mono-2.10/lib/mono/4.0
MonoVersion 2.10
os.arch amd64

This this results in x64 only builds and trying to x86 builds results in an error "Unmet requirements: Mono2.0_x86 exists"
Any thoughts on why the system variables are not suffixed with _x86, I'd expect that both x86 and x64 would be detected.

Thats really only a minor issue though compared to the fact that I've specified on the project build step as follows:
MSBuild version: Mono xbuild
MSBuild ToolsVersion: 4.0
Run platform: x64 or x86

and still the build agents want Mono 2.0 and not Mono 4.0. This is causing a problem as i end up with an error "error executing task MSBuild: Unknown tools version: '4.0' . Known versions: '2.0' '3.0' '3.5'"
Now thats the one I really want solved.

Any ideas?
2 comments
Comment actions Permalink

Hello Matt,

Looks like it is a bug. Could you please create an issue in the tracker for this.

Thanks in advance,
Marina

0

Please sign in to leave a comment.