Build Variables

How do I access list of build variables?

I see screenshots of people just typing "%" to see them like intellisense

or the icon.. but in my TeamCity v6.0.3, I don't see any of them.. is there some configuration to turn that on?

6 comments
Comment actions Permalink

Hi Lee

There should be an icon on right side of text boxes:
icon.PNG
Do you have it displayed?
If not, please tell what browser and OS do you use.

Michael

0
Comment actions Permalink

build.jpg

No Icon on textbox or in message which says click Icon with image missing..

This is in IE9, but I also tried it in IE8 and FireFox.. no icons

0
Comment actions Permalink

Hi Lee
the following issues seems to be related: http://youtrack.jetbrains.net/issue/TW-16377, http://youtrack.jetbrains.net/issue/TW-16409, http://youtrack.jetbrains.net/issue/TW-16336. The fix will be available in the next 6.5 EAP/release.

0
Comment actions Permalink

Lee,

Just in case, to make sure we're talking about the same issue.

Please reload the problem page, and check for JavaScript errors in the browser and errors in teamcity-server.log

Michael

0
Comment actions Permalink

No javascript errors

Nothing in the logs that would explain why they don't show up... there are errors but they are sql errors when our db does nightly maintence

However, in catalina<date>.log

it does say..

May 10, 2011 10:17:08 AM org.apache.tomcat.util.http.Parameters processParameters
WARNING: Parameters: Invalid chunk '' ignored.

0
Comment actions Permalink

Hi Lee,
sorry, I prematurely concluded the bug is fixed, it isn't. Please watch/vote for this issue: http://youtrack.jetbrains.net/issue/TW-16532.

0

Please sign in to leave a comment.