TeamCity web server crashes soon after starting

We're running TeamCity 6.0.2 (build 15857) on Windows Server 2008 R2.

I was initially having a problem with a VCS error on all our projects (it was an out of memory error but I didn't write it down).

I tried restarting the TeamCity web server service but it didn't shutdown.  After about 10 minutes I killed the process.

Now the TeamCity web server service starts and runs for about a minute before it stops all by itself.  Each time I start it it stops after about a minute.

Does anyone have any suggestion about how to get it going again?

I have attached log files that record starting the server twice in case that's any help.



Attachment(s):
TeamCity logs 1.zip
1 comment
Comment actions Permalink

Upgrading to 6.0.3 seems to have fixed it.  Phew!

The VCS error was:

Unable to collect changes java.util.concurrent.ExecutionException: jetbrains.buildServer.vcs.VcsException: java.lang.OutOfMemoryError: unable to create new native thread

It has also cleared up with the upgrade.

0

Please sign in to leave a comment.