Having difficulty pinging agent

I have a windows xp vm on my local machine that I want to use to test a new agent configuration before we get our ops to setup a proper vm with proper routing etc.

My network setup requires that I run my vm adapter in NAT mode. I have installed the buildagent on the windows machine, have set Own Address to the ip address of my host computer, and have forwarded the 9090 port to the vm. The forwarding seems to be working, I can ping my host machine from the teamcity server, and I can telnet on port 9090 only when the buildagent is running on the vm

But, the agent complains that the teamcity server can't ping it.

How is teamcity pinging the agent?

Any suggestions for getting this to work?

3 comments
Comment actions Permalink

Hi David

You need to specify ownAddress property in buildAgent.properties file, and set it to external IP of gateway.

Michael

0
Comment actions Permalink

That is what I have done, I've set the ownAddress to the IP of the gateway/host that accessible from the box with the teamcity server. I haven't been able to get it work.

How does teamcity ping the client?

0
Comment actions Permalink

hi David

Sorry for late response.
That's not a ping in terms of  ICMP. The server just opens HTTP connection to the agent on specified port, and makes XML-RPC request.

Host OS has a special virtual network adapter, and can communicate to guest machines directly. Actually there is no need to forward ports, and specify ownAddress until you need to access the guest machine from other computers.
Recheck once again that guest OS does not block the connection by a firewall.

When you forward a port, VMware NAT service starts to listen on it. So telnet connection is opened even if the agent within guest OS is not started.
Send

GET / HTTP<enter>
<enter>

command, and check that the agent actually returns a response.

If that doesn't help, please enable debug logging, restart the agent, reproduce the error, and send us teamcity-server.log, teamcity-xmlrpc.log, and teamcity-agent.log

Thanks
Michael

0

Please sign in to leave a comment.