Build agent - Incompatible runner: Powershell

I have the following environment:

Windows Server 2003 sp2 (lots of other apps installed, IIS, apache, redmine, mercurial, visual studio, tfs, sql server)

TeamCity Professional 6.5 (build 17795) -

  • both webserver and build agent services installed, both running on an account with admin rights (for now to remove permissions as an issue).
  • The Admin -> server config -> bundled plugins list confirms that the powershell runner is installed.
  • Integrated with AD via LDAP successfully



Powershell 2.0

$psversiontable output:


Name                           Value         
----                           -----         
CLRVersion                     2.0.50727.3620
BuildVersion                   6.0.6002.18111
PSVersion                      2.0           
WSManStackVersion              2.0           
PSCompatibleVersions           {1.0, 2.0}    
SerializationVersion           1.1.0.1       
PSRemotingProtocolVersion      2.1      
    

I have set up a mercurial VCS root, the test connection for that works.

I have some psake scripts that builds my project, so I created a powershell build step, with, I think, the correct powershell command:

     & {Import-Module .\tools\psake\psake.psm1; Invoke-psake .\psake-common.ps1

That command should run the default psake task and compile the project.

The build trigger is "Triggers build after a VCS change is detected"

Checking on the Agent Requirements, there is one condition: powershell_x86 exists and also shows no agents are compatible, and that the only agent I have is incompatible, because the above condition is unmet, which isn't strictly true.

Checking on the agent status screen, the agent is connected, authorised and enabled

Checking on the build runners tab I am informed that:


     This agent supports the following build runners:


     Command Line: Simple command execution

Anyone have a clue as to how I can tell the build agent that it has access to powershell?

If more information is required I will, of course, try to provide.

Cheers

NJ

Message was edited by: nacho jammers - trying to sort formatting issues

Message was edited by: nacho jammers - formatting again

2 comments
Comment actions Permalink

Hello,

Please check your build agent was auto-updated right. Please try to do the following:
- stop TeamCity Build agent service
- remove <agent>/system, <agent>/plugins and <agent>/tools folders
- start TeamCity Build Agent windows service once more
- wait 5-7 minutes for build agent to upgrade. (Note, build agent service may be shown as stopped during the autopupgrade)


Build agent is in 'buildAgent' folder in TeamCity server .exe installation

Please attach zipped <agent>/logs folder here or email it to teamcity-feedback@jetrbains.com

0
Comment actions Permalink

thanks for the reply, that was the problem, although I solved it by reinstalling the build agent.

thanks for the help!

0

Please sign in to leave a comment.