Running backup through Admin UI causes performance issues

Hi,

I tried running the backup through the admin UI and noticed TeamCity was rather sluggish.  Has anyone else experienece this type of behavior?  It was happening during the database dump.  I also tried killing the process and it never finished.  As a result I had to restart the teamcity server to clear it up.

Thanks,
Jay

2 comments
Comment actions Permalink

Jason,

We'll need additional info

  • TeamCity version
  • Type of used SQL DB
  • Size of your database
  • Size of resulted backup


What process did you have to kill, Tomcat?
Is it reproduced continuously?

Thanks

0
Comment actions Permalink

TeamCity Version: 6.5.1
DB: mysql  Ver 14.12 Distrib 5.0.77, for redhat-linux-gnu (x86_64) using readline 5.1 (InnoDB)
Size of DB: -rw-rw----  1 mysql mysql 5.4G Jul  1 10:01 ibdata1
Size of backup: I never let it finish as it was dramatically slowing down TeamCity

I stopped through the UI but on the system couldn't find anything, I ended up restarted teamcity and it seemed to clear up the Admin UI and things were running smoothly again.
I have not tried to continuously reproduce since I did not want to impact users.

0

Please sign in to leave a comment.