Unexpected TeamCity reporting behavior when suites is selected under the Tests tab when artifacts are returned

Unexpected TeamCity Reporting Behaviour

================================

After the completion of a testsuite, the Tests TAB displays a "<no suite>" Name  in addition to the expected name of "Domino Race".  This is seen when the "suites" is selected from the View drop down.  The "<no suite>" Name appears when a testcase returns an artifact. 

 

Expected TeamCity Reporting Behavior

=============================

I would have expected that only the "Domino Race" would be displayed.  

 

 

Tests TAB    View=suites

===================

Name

Domino Race

<no suite>

 

 

Service Messages

==============

print "##teamcity[testSuiteStarted name='Domino Race'] "

 

print "##teamcity[testStarted name='Domino Spacing at .75 inches'] "

 

print "##teamcity[publishArtifacts '/home/jk121225/odbc_log/output1']"

 

print "##teamcity[testFinished name='Domino Spacing at .75 inches'] "

 

print "##teamcity[testSuiteFinished name='Domino Race'] "

 

 

Build Log

=======

[10:19:23]: Checking for changes

[09:13:48]: Clearing temporary directory: /opt/TeamCity-Agents/jk121225/temp/buildTmp

[09:13:48]: Checkout directory: /opt/TeamCity-Agents/jk121225/work/f16ae2786f00c47e

[09:13:48]: Start process: /home/jk121225/hpvgtst_prototye.sh

[09:13:48]: in: /opt/TeamCity-Agents/jk121225/work/f16ae2786f00c47e

[09:13:48]: Domino Race

[09:13:48]: [Domino Race]

[09:13:48]: [Domino Race] Domino Spacing at .75 inches

[09:13:48]: [Domino Spacing at .75 inches]

[09:13:48]: [Domino Spacing at .75 inches] ##teamcity[publishArtifacts '/home/jk121225/odbc_log/output1']

[09:13:48]: [Domino Spacing at .75 inches] Publishing artifacts

[09:13:48]: [Publishing artifacts] Paths to publish: [/home/jk121225/odbc_log/output1]

[09:13:48]: [Publishing artifacts] Publishing files

[09:13:48]: [Domino Race]

[09:13:48]:

[09:13:48]: Process exited with code 0

[09:13:48]: Publishing artifacts

[09:13:48]: [Publishing artifacts] Paths to publish: [teamcity-info.xml]

[09:13:48]: [Publishing artifacts] Publishing files

[10:19:23]: Build finished

2 comments
Comment actions Permalink

Hello, Calvin,

What TeamCity version are you running?

0
Comment actions Permalink

We're using 5.1.4 13550

0

Please sign in to leave a comment.