Maven 3 support in TeamCity 6.5.2

I've just upgraded my installation to 6.5.2 in the hope of getting Maven 3 working. At the moment all my builds appear to be using maven 2.2.1 and when I look in buildAgent/plugins/mavenPlugin/lib there is only a maven-2.2.1-uber.jar and no corresponding maven 3 jar file. Am I missing something?

Thanks,

James

1 comment
Comment actions Permalink

Hi James

In TeamCity setup package we distribute Maven 2.2.1, but you can use other versions installed externally.
It can be specified

  • by MAVEN_HOME environment variable on build agent machines
  • in Maven home path option in build runner settings


Michael

0

Please sign in to leave a comment.