.Net Framework Not Detected under Agent run under User Account

I've been trying to setup a build server on my Windows 7 machine.  It worked fine when I ran the Build Agent under the SYSTEM account.  But, because I'm building XNA projects, I found some information that I have to run it under a user account.  So, I've got the agent setup to run under a user account, but when I do that, the agent does not detect the .Net frameworks installed (nor the XNA frameworks).  I've looked everywhere for an answer but could not find one.  What do I have to do to the user account to get the agent to detect the .Net frameworks?  I've setup a VM for XP and have it running the agent under a user account and it works fine.  But, we need to run it under Windows 7 for XNA 4 so I need to get it working under Windows 7.  Thanks.

1 comment
Comment actions Permalink

I ended up figuring out a couple of things.  For one, the agent wasn't getting updated correctly.  I had to run it under console for Windows 7 to give it enough rights to update.  Once I did that, it worked fine for .Net as a service.  But, to compile XNA, I have to run it in a console and then it will compile the XNA stuff successfully.  Also, to setup on startup to launch the console, I couldn't launch from another batch file.  It wouldn't find the java classes.  So, I just linked to a copy of the agent batch file and modified it to always do start.  In Windows 7, closing the console window does not kill the agent so it works similar to a service at that moment.

0

Please sign in to leave a comment.