Executable bit lost when cloning with Mercurial ?

Dear All,
Recently I tried to move to Mercurial and the checkout did by Teamcity seems to lost the Exec bits.

From the command line, if I do a:
hg clone --uncompressed http://serverhg/hg/appli
ls -l

-rwxr-xr-x  1 buildmaster buildmaster 2494 Aug 23 16:11 install.sh


My script have the bit correctly set.

However during the teamcity checkout, the flag is lost.

ls -l /opt/teamcity/work/8ac0451232b2626e/appli/install.sh
-rw-r--r-- 1 buildmaster buildmaster 2494 Aug 23 15:41 /opt/teamcity/work/8ac0451232b2626e/appli/install.sh


In both case, I run under the same 'buildmaster' user.

Is there anyone having an idea ?

Thanks

Arnaud
2 comments
Comment actions Permalink

I just figured out the problem coming from me as usal :-)

So just for the record:
Actually the server was configured to checkout "on the Server". My server is running windows, however my build was targetting linux.
At the end of the checkout, data was copied to Linux, causing the Bit executable to be lost. Another issue was the file different only by the case (Linux build) which were dissapering.
After having deleted the VCS Root (as it seems to always use the cached version on the windows platform), and configured for checkout " on the agent side", everythong went well.

Arnaud

0
Comment actions Permalink

Thank you for sharing the solution!

0

Please sign in to leave a comment.