Windows Authentication failure

OK so I have configured TeamCity to use Windows Authentication as per this help file: http://confluence.jetbrains.net/display/TCD65/Configuring+Authentication+Settings

However, when prompted to create an administrator account, I cannot login with a "Failed to set up administrator account. Incorrect username or password." error.

I am entering my username like this: ABC\username, replacing the ABC exactly with the domain name, and username exactly with my domain username. I've had other members of my team try as well so I know it's not just a password flub. I notice that when I enter nonsense for the domain I get the same error, so I can't tell if we're successfully connecting to the domain in the first place. I guess that we are not.

I've set the jcifs.netbios.wins property to the WINS ip, although I get the same error .

I am at a larger enterprise so there are probably some things our IT has set up that I don't know about that are mucking with us. I don't know much about Windows Authentication.

Is there a log somewhere that might provide us some clues as to what is going on?

2 comments
Comment actions Permalink

That's probably an issue with resolution of NetBIOS domain name.
Try to specify the domain name in full DNS format, like domain.local

0
Comment actions Permalink

Ah, of course. That was it.

0

Please sign in to leave a comment.