Team City does not start and code folders dont exist any more.

Anyone encountered this behavior before with TeamCity?
I installed teamcity server and agent on the server and set up multiple build configurations that worked perfectly. Now after two to three weeks, after a long gap, I go back to the server to work on it - and nothing is working. The UI is not loading up (http:/localhost), I dont see the code folders that had the code pulled from TFS two weeks back. I cant seem to access anything. I try to activate the Team City system tray notifier and pops up a message "unable to connect to TeamCity server". I went into services to see if Build server and agent are running. And they are. I stopped and started them again, just in case, but that didnt fix it. I am quite stumped as to how everything 'disappeared' completely. Just to add to this.. TeamCity and Build configurations worked perfectly for almost a month when we were constantly working on it.

1 comment
Comment actions Permalink

are there any errors in teamcity-server.log?

0

Please sign in to leave a comment.